1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Help with Unimount problem

Discussion in 'Western Plows Discussion' started by EKennett, Aug 28, 2010.

  1. EKennett

    EKennett Junior Member
    Messages: 15

    Hey all I just bought a used 7'6" Unimount for my truck, it's the pro steel model with quad trip springs. I just finished up the install and hooked everything up for the first time today. Lucky me, it all works. Here's where I'm running into a problem. When you are dismounting the plow from the truck you are supposed to put the controller in the "float" position and push the lift arm all the way down by hand. That gives you the necessary slack in the chain to maneuver the lift frame for uncoupling. I cannot for the life of my manually push the lift arm down to the fully depressed position. It just wont budge once the weight of the plow blade is on the ground. Help?
  2. SnowMatt13

    SnowMatt13 PlowSite.com Addict
    Messages: 1,559

    Snowplow will not lower,
    lowers slowly, or will not float.
    1. Incorrect hydraulic fluid for the
    2. Quill is adjusted in too far.
    3. Lift ram packing nut is not
    adjusted properly.
    4. Cartridge valve coils are not
    activating properly.
    5. Cartridge valves are
    contaminated and are sticking.
    6. Cartridge valves are damaged.
    1. Use recommended hydraulic fluid.
    (See page 23.)
    2. Turn quill out.
    3. Loosen lift ram packing nut.
    4. Repair or replace coils, wiring or
    cab control.
    5. Clean or replace valves. Find the
    cause of contamination. Flush
    and refill system.
    6. Replace cartridge valves.
  3. JohnnyU

    JohnnyU 2000 Club Member
    Messages: 2,040

    Joystick controller? Push it back into the "float" position one more time, making sure that the red LED stays lit on the controller. Step out of the truck and push the ram down. As long as the controller is still powered, the valve will remain open and you should be able to push the lift ram down.

    If not, follow the troubleshooting advice that Matt posted.
  4. EKennett

    EKennett Junior Member
    Messages: 15

    I changed the fluid and adjusted the quill. I get a nice steady lower speed but the problem is once the plow blade contacts the ground I cannot manually push the lift ram in any further. This is with the joystick still in float mode and power on. I think I am going to try adjusting the packing nut. What do you guys use to grip that nut? It's bigger than any tool I have. Is it ok to use a torch on it to loosen it up?
  5. Western1

    Western1 Senior Member
    from MI.
    Messages: 752

    No torch! Try some PB blaster and let it soak. There maybe some pitting on the lift ram,very common when the ram is not retracted or water gets in there for a period of time. Try spraying it down and raising the ram then spraying it again and dropping the plow. Sometimes its necessary to stand on the lift channel with all your weight! When the plow is raised inspect the lift ram for pitting. It might be good to use some fine sandpaper to smooth ram or just replace the ram and packing. I had one that I couldn't retract even standing on it! ended up replacing the ram and packing and it was smooth after that.
  6. bechbru2

    bechbru2 Junior Member
    from pa
    Messages: 15

    are you sure that it is in float. with the plow down and in float drive up on some blocks and make sure the plow stays down on the ground. if not its wiring.
  7. firefighter1406

    firefighter1406 Senior Member
    Messages: 345

    I am having the same problem with my unimount MVP.......subscribing
  8. EKennett

    EKennett Junior Member
    Messages: 15

    I'm reasonable sure its in float. The green float light stays on on the handheld controller when I am trying to push the lift ram in. I actually don't know what's going on because now I can't operate the plow at all. It sounds like the motor relay is not engaging when I press any of the buttons on the controller so I'm gonna hafta troubleshoot that now too. :mechanic:
  9. snowplowpro

    snowplowpro Senior Member
    from NJ
    Messages: 926

    check the solenoid(under the hood) that can be bad or there may be a loose wire some were or check on the pump itself theres is that little plastic box there is wires connected to the slolenoids in there one of them maybe loose or broken or go to westerns website look it up on the manuals
  10. jomama45

    jomama45 PlowSite.com Addict
    Messages: 1,190

    A few things:

    I wouldn't mess with the packing nut just yet.

    NO torch!

    Try putting the front tires up on wheel ramps, uneven ground, something that will allow the plow to drop farther on it's own before turning any wrenches.

    I've kicked the chain on mine already when my own weight wasn't enough to get it back down.
  11. affekonig

    affekonig Senior Member
    Messages: 909

    I've had this happen a million times and I figured it was just "stuck" because that inc or two is always out. I've kicked the chain, stood on the lift arm, beat it with a ammer, but the easiest way I've found is to use the plow's own weight and just hang the truck off somethingso the plow can drop lower than the level the tires on (of lift the front of the truck as bechbru said).
  12. EKennett

    EKennett Junior Member
    Messages: 15

    OK, that worked. I jacked up the front of the truck and I was able to get the lift arm fully retracted. But that can't be right. Should I really have to lift the front end of the truck up every time I want to dismount the plow??
  13. Western1

    Western1 Senior Member
    from MI.
    Messages: 752

    No! Is there pitting? Clean it up and lube it with penetrant. Then work it up and ten times jacked up.
  14. My76f250

    My76f250 Senior Member
    Messages: 105

    Heres my input....I just got rid of an f150 with a cable pump on it..I had problems pushin the lift arm down too...i used to just put my foot into the chain and push on that. I have a bad shoulder so it works easier that way for me
  15. EKennett

    EKennett Junior Member
    Messages: 15

    A little bit of pitting. I hit it with 220 grit sandpaper then lubed it up with Seafoam Deep Creep and worked the plow up and down a few times to distribute it.
  16. R3Dside

    R3Dside Member
    Messages: 86

    I have the SAME EXAST problem (almost looked to see if I wrote this thread haha) I bought a used 7.6'' unimount pro plow and I cant get that lifting ram to go all the way down for the lift of me (even beat it a little with a maul) I had to end up adding one link to of slack to the ram to get the plow back on.

    Im new and this is my first plow, but what is the pitting mean? Im running out of ideas on how to fix this. And yes, the controller says the float is on.
    What is the quil?
    Im changing the fluid for my first time today also, hopefully looking at it all better, i can get a new idea on how to fix this. The manual say just push the channel down, but it will not move in the slightest.

    Please help, thanks!
  17. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,392

    Sometimes what i have seen, with the pitting on the lift ram you get some air traped in the lift ram housing. If you loosen up the 1/4 allen screw on the side of the lift ram, that will expell fluid, and junk from the cylinder. If you unscrew this allen, make sure to recheck you fluid after as you are going to lose a little bit. keep us posted as to your success.
  18. JohnnyU

    JohnnyU 2000 Club Member
    Messages: 2,040

    If the reservoir is overfilled, it will prevent the lift ram from retracting all the way into the housing. Check that first.