1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

help snoway mtd not moving

Discussion in 'Truck & Equipment Repair' started by GTBlazer, Jan 29, 2014.

  1. GTBlazer

    GTBlazer Junior Member
    Messages: 1

    Newbie and hoping to get some advice. At the end of last season I purchased a used 6.8 plow side only Sno-way MTD (supposedly in good working order). Independently I purchased a used controller and harness and created my own power harness using 4 gauge wire with an Anderson connector. The negative is grounded directly to the battery and the positive is going through a cooper bussmann 150A circuit breaker. After I got it all hooked up found out that the motor was not spinning. Solenoid tested ok so I took the motor apart and cleaned the carbon off the brushes and that solved that problem. Motor spins great. Originally I was getting 12v at the red/white wire on the solenoid but lost it, 10amp fuse was good and the controller would flash and light up, so I figured it was the receiver. Tried dealing with a local guy but they didn't seem to have the time and since I been getting a lot of info from here and seeing that basher is very helpful, I sent him the business and purchased the wired pro-controller and receiver from him. I installed it and getting 12v at the coils and tested the functions with a test light. Motor spins and test light goes out with hitting the function but I get no movement from the plow, plow remains in the up position. Thought it might be clogged pickup filter, vent cap or stuck valve so I took the pump off brought it inside (got tired of freezing my butt off outside) cleaned the vent cap (really wasn't dirty) took the reservoir off, pick up filters were clean and not an issue. Next I started to take the valves out to inspect. There didn't seem to be any stuck or clogged, can manually push on them and they move fine. With the valves out I tested the pump, able to manually turn the pump and fluid is being pushed through. Where I'm having an issue is with bench testing the coil and valve. I'm under the impression that you should be able to take a 9v battery and touch the leads to the coil and the valve should move but I can't get any one of the six red coils to activate any of the valves. I find it hard to believe but is it possible that all six coils are bad? Or am I doing something wrong. Hate to throw money at something if it is not necessary. Any advise as to which way to go would be appreciated. Thanks
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    Check the pressure relief

    Try using a jumper wire and 12volts to the coils.

    It is unusual but not impossible to have 6 bad coils.

    Does the motor run when you engage down pressure?