1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

help! problems with a meyers sno ex 575

Discussion in 'Ice Management' started by dozerman550, Dec 1, 2004.

  1. dozerman550

    dozerman550 Junior Member
    Messages: 2

    Hi guys, I was wondering if anyone has any ideas, my husband and I are both stumped........ :confused:

    We have a sno ex 575 that we have used on the same truck for 3 years. This year we can't seem to make it work with salt, it works fine empty, but when you get salt down to the spreader the motor can't get started by itself, if you give it a push it will take off and work.

    The motor is brand new, as the old one finally failed, the magnets were actually broke loose of the housing on the motor, if that is a clue at all......

    we checked all the wiring, everything seems fine......we even have an older western spreader hooked up on the same truck and wiring, and it is working as it should. Also, the spinner seems to spin freely by hand, it doesn't seem as if it is froze up.

  2. Highpoint

    Highpoint Senior Member
    Messages: 241

    Have you tried hooking the spreader up directly to a 12 volt source bypassing the controller? You can unplug the spreader in back and carefully hook a pair of jumper cables to the plug (make note of which way the auger is turning before doing this. The auger should be spinning as to draw material down). This may take some doing as to NOT let the two ends touch (make a jumper wire or two). Put some salt through it this way. If it works, the controller is probably bad.

    The only other alternative is to replace the entire lower unit that is made up of the auger,spinner,gearbox,motor and housing. Gear box may be bad. Good Luck.
  3. BillNero

    BillNero Member
    Messages: 34

    SnowEx 575

    You may want to take a volt meter and check the voltage out of the harness right at the spreader end. If memory serves me, voltage should read 4.7 volts at the lowest speed and full battery voltage at full speed. Anything less than that and I would suspect the controller.

    Central Parts Warehouse
  4. dozerman550

    dozerman550 Junior Member
    Messages: 2

    what we tried

    We were also thinking possibly the gear box, just hate to dish out $300 guessing.....

    I did try a jumper on a battery, sitting on the bumper, and it did seem to work better, so I then ran aprox. 10 ft 10 gauge leads to the same battery, and it couldn't quite take off, if I kept tapping the connection it would take off some times.

    As far as the voltage, I am reading 12.8 volts, but do pick up a drop to about 11 volts when I turn unit on. I also had noticed that the motor said 3 amps on it when we replaced it, so I hooked a 10 amp fuse in line with my spare battery, it popped it in less than 1 minute. I did not check to see how many amps I am actually drawing my meter will also pop at 10 amps.......any body know what they are actually rated for? I wouldn't think 3 amps is right.

    any way to check the gear box?
  5. finnegan

    finnegan Senior Member
    Messages: 313

    you might have a stuck brush in the 12volt motor which would lead to excessive current draw