1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Help Poly caster problem

Discussion in 'Fisher Engineering Discussion' started by zak406, Dec 10, 2014.

  1. zak406

    zak406 Junior Member
    Messages: 14

    Just got into the snow business this year after being in the landscaping business for the last 8 or so. Anyway I bought a blizzard speed wing plow brand new and was going to purchase a buyers salt dogg spreader. However a guy I knew had a poly caster for sale and a close friend told me it was a better spreader. Which I got cheaper than the new salt dogg. Long story short I bought it.

    Now for my issue. Since the day I bought it the spreader has not worked right. My initial problem was it would work occasionally. If you wiggled the rear wiring harness connection it would start working again. I finally took it to a shop near by yesterday. I had the salt spreader working when I got it there. They called and told me I needed a new connection in the back and they cut and spliced everything together with new plugs. The problem I have now is when I plug it in it is on all the time regardless of whether or not the controller is on. The other thing is the only thing that works is the spreader motor. The conveyor does not work now. I also do not have any control on spinner speed. Essentially the controller in the cab doesn't work now. The controller is brand new just installed it last week.

    I know when I took it to the shop that although it would sporadically stop working (im assuming because of the bad rear connection) the spreader worked as it should when it would run. I had full control on the conveyor and spreader. As well as the conveyor would also work. The controller also controlled everything as it should.

    One last note the code I was throwing when the spreader wouldn't run was 9 beeps. Occasionally I would also get a continuous beep that would not shut off (which once again im assuming that was a no connection fault).

    Does anyone have any advice or suggestions before I rip the rest of my hair out? Thanks all.
  2. kimber750

    kimber750 PlowSite Veteran
    Messages: 4,676

    Take it back to the shop that "fixed" it and tell them to do it right this time.
  3. zak406

    zak406 Junior Member
    Messages: 14

    And what would that include? The shop is extremely reputable.... I looked over what they did and there is no difference between what was done and what you see on the old set up. My thought is the module is messed up. I however am concerned by the fact that the spreader module obviously worked correctly when I took it in. With the exception of the connection issue in the rear. They also think its the module. However like I said im concerned because it worked when I took it in.
  4. kimber750

    kimber750 PlowSite Veteran
    Messages: 4,676

    I am guessing you have one of the spreaders with the module mounted out on the spreader. You can double check that the shop hooked everything up correctly but still you paid them to fix it, why should you have to double check their work? Much less fix their screw up.

    Here is link for manual to spreader I think you asking about. You can look thru it for the wiring diagram. http://library.fisherplows.com/fisherplows/pdffiles/94212.01_081513.pdf
  5. zak406

    zak406 Junior Member
    Messages: 14

    Looked it all over its hooked up right. Took connections apart and we have power going back. The shop I took it to basically told me to go to hell this morning when I talked to them. At this point im assuming its the module. Also it is a spreader with module mounted in rear.
  6. zak406

    zak406 Junior Member
    Messages: 14

    Got off the phone with fisher not to long ago. Theyre in the same boat as I am thinking its either the controller or module. The cab controller is only a week old. The module is also only an year old. Looking to replace the module.
  7. Dublin Plow

    Dublin Plow Member
    Messages: 47


    Check your harness..from the battery all the way to the module..make sure it didn't ground out...yes it's possible that the module is bad but if that harness has wiggled and caused a short a $500 module won't solve anything
  8. 07PSDCREW

    07PSDCREW Senior Member
    Messages: 873

    I wonder if they cut the connector off while the unit may have been powered on or had power supplied to the rear harness?? That could screw something up...
  9. White Gardens

    White Gardens 2000 Club Member
    Messages: 2,665

    That's what I've been thinking. This "awesome" shop didn't cut the power completely before doing their work.