1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

help install question wire problem

Discussion in 'Meyer / Diamond Products Discussion' started by andrewlawnrangr, Nov 17, 2006.

  1. andrewlawnrangr

    andrewlawnrangr Senior Member
    Messages: 339

    i have installed a classic setup on my 01 f-550. now i have moved on to the wire part of it. i have the harness for the touchpad power and ground and solenoid. i ran the touchpad wire into the truck and then to the front to the pump. installed the solenoid and attached the white wire to the front of the solenoid. then each side of the solenoid got a power cable and then attached that to the battery. installed the ground to battery and to the pump.... the orange wire also goes to the power on battery where does the blue wire which is attached to the touch pad wire harness go to??:dizzy:
    am i doing everything correct??


  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Andrew,THE ORANGE WIRE IS GROUND NOT POWER!:eek: Hope you didn't fry the touch pad! It gets attached to one of the solenoid mounting bolt's(on your under hood solenoid)The blue wire is your hot wire to power the touch pad.Connect it to a keyed hot terminal in the fuse panel.
  3. Luppy

    Luppy Senior Member
    Messages: 325

    Check out the wiring diagram on page #10 of the manual
    which is available in .pdf format online here.
    It helped me last year when I replaced a slik stick with
    a touchpad.
  4. andrewlawnrangr

    andrewlawnrangr Senior Member
    Messages: 339

    hey thanks guys i fixed it and got it workin the touch pad is fine. secured the solenoid with some self tappers and put the ground behind it. thanks again........now just some snow would be nice...xysport
  5. oakvillerex

    oakvillerex Member
    Messages: 65

    i did have the same problem before i found this awsome site and it turns out that if you do hook up those wires backwards there is a reverse polarity circuit in the controller that just pops also your power should be fused i believe 10 amps anyways long story short i gave the controller to my father and he fixed it, works like a champ now