Snow Plowing Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
11 Posts
Discussion Starter · #1 · (Edited)
I need some help on my haldex plow pump that I purchased from northern tool about 8-10 yrs ago.
I am using it on a sidewing on a dually truck to run the left/right and lift. But can only get the rear ram to go out about a Inch and nothing more.
I even used a cumalong and tried pulling the cylinder(double acting) while hitting the switch and still the same.
The hoses are plumbed correctly, each coil is magnetized when activated, fluid is flowing. But can't figure it out.


Any ideas?
 

· Registered
Joined
·
2,184 Posts
Need some more info. Have you done any service on this unit. Have you taken the resivior off and see what is going on in there. Also the coils maybe magnetizing but do the valves actually have action. You need to take them out to check this. There is also a cross over relief set up on these. Take that out and make sure the spring is not broken and make sure the ball is good. Sounds like something is stuck there.
 

· Registered
Joined
·
2,184 Posts
Not going to ruin my eyes trying to see that. Find the valve that makes it go left, right. Take the coil9s) off, remove the valve(s) and bench test it. Sounds like it is/are bad and not working or junk is in there. Also you did not state if you have serviced this pump or not. How does the fluid look as well as the screen.
 

· Registered
Joined
·
760 Posts
Are you sure that something is not binding?

Disconnect the ram from the wing and try moving the wing by hand (or jack or come along etc.) too see if it is binding.

While you have it disconnected from the wing remove both hoses then check to see if the piston moves in and out freely.

Posting pictures of any data plates on the motor and/or pump may be helpful.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top