1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Ground wire keeps melting! Fisher 7.5'

Discussion in 'Truck & Equipment Repair' started by ndeubert, Jan 25, 2015.

  1. ndeubert

    ndeubert Junior Member
    Messages: 3

    Hey Everyone, I have a 7.5' fisher minute mount with the 2 plug harness. I installed it about 3 years ago and it has worked fine year after year, just changing the fluid every year. Except this year I went to hook it up (in prep for the 2' of snow we are supposed to get tomorrow) and the ground wire from the harness melted and burnt out when I tried to use it. The plow moved a little bit but slow and did not raise up all the way until i smelled the wires smoking. I proceeded to replace all the ground connections on all the wires and the solenoid just to be sure and it did it again. I dropped the fluid reservoir and filled it with fresh fluid in case there was sludge making the motor work too hard and melt the wires and redid the ground again and same problem. So then thinking there was a short in the harness I cut all the wires to the lights and that didn't matter either. Does anyone have any idea what could be going wrong? Did my controller (fishstick) go bad? Did the coils on the pump go bad and short things out?

    The first time I hooked it up I was a little careless and there was probably snow connecting both the + and - the terminals on the pump. Could I have fried the pump? The wire that keeps melting is the small gauge black and orange wire in the 9-pin plug. I attached the mechanics guide that matches my plow, unfortunately it doesn't cover melting wires.

    Any help would be greatly appreciated as I would like to get this working before the snow hits tomorrow!

    Attached Files:

  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,391

    That blk/og goes alotta places. Where did it melt?
    Was anything done recently to the trk or plow?
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,391

    So we're all crystal.



  4. ndeubert

    ndeubert Junior Member
    Messages: 3

    I haven't done any work to the truck, maybe replaced an ignition coil and topped off the tranny fluid but that's it. And the plow has sat since last winter in the driveway. I did't do anything until yesterday after it wasn't working.

    I tied it into the ground in the head light circuit (since I had that harness opened up) and it kept melting right there. Then I tied it directly to ground and the whole wire in the harness melted. I cut open the harness last night and the only wire in it that was melted was the black/orange.
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,391

    Well need to start by unplugging parts of the harness and see if it still gets hot
  6. gasjr4wd

    gasjr4wd Senior Member
    Messages: 287

    Without me finding my reading glasses and looking at what you sent...
    Clean out the plugs. Maybe your ground is acting like a fusible link? Turn off everything and look for any power in that ground wire. It should be none. I assume you are talking the pump wiring and not the lights?
    Try to leave the OEM vehicle alone as much as possible. It's barely sized for what they want it to do. You start adding things like a plow and plow lights it quickly overloads it.
    In general the grounds should always be large and to the frame. I always make the ground from the battery larger than factory and add additional grounds.
    Think of it like this, add up all the power of all the hot wires, and then look at the size of the ground. It's always smaller.
    I can never understand why isn't the ground larger from the factory?!?!
  7. ndeubert

    ndeubert Junior Member
    Messages: 3

    Well I ended up figure it out. Looks like the main battery cable going from the solenoid to the motor burned out. I ended up disconnecting all the lights so it was just the solenoid, controller, and plow. Then hooked up jumper cables from the solenoid and battery to the motor and it worked fine, but not without the jumpers. So i got a new power cable and its working well now.

    Thanks for everyone's help though.