Snow Plowing Forum banner
1 - 14 of 14 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I've replaced bulbs in the past and everything worked fine. not this time. I have discovered a cut wire connected to a nut on the inside housing of my snow plow light. Its a snow way. I'm thinking of reconnecting, but don't know where.
 

· Registered
Joined
·
7,368 Posts
I'm guessing that's a ground wire.
 

· Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
I've replaced bulbs in the past and everything worked fine. not this time. I have discovered a cut wire connected to a nut on the inside housing of my snow plow light. Its a snow way. I'm thinking of reconnecting, but don't know where.
Umm,take the other housing apart and take a look see.
I've already checked. There is no ground or any other wire as well. Thanks any ways
 

· Registered
Joined
·
7,368 Posts
I've already checked. There is no ground or any other wire as well. Thanks any ways
"Cut wire connected to a nut"
Most plow lights are grounded to the housing through a rivet or bolt in the mounting flange.
If there are 2 wire ends, one comes from the plug, the other is connected to the nut. Would be fairly certain it's supposed to be connected.
Are the wires the same color?
Or am I missing something here?
Picture?
 

· Registered
Joined
·
4,305 Posts
"Cut wire connected to a nut"
Most plow lights are grounded to the housing through a rivet or bolt in the mounting flange.
If there are 2 wire ends, one comes from the plug, the other is connected to the nut. Would be fairly certain it's supposed to be connected.
Are the wires the same color?
Or am I missing something here?
Picture?
Yes, we're missing something. I think its probably be good if all of us ,myself included give as much info in the initial post, including pics. Many of these problems could be solved by the first couple of members that view them. I thought the same about broken wire, now just guessing, maybe it pulled out of the plug? But who knows!
 

· Registered
Joined
·
6,187 Posts
Yes, we're missing something. I think its probably be good if all of us ,myself included give as much info in the initial post, including pics. Many of these problems could be solved by the first couple of members that view them. I thought the same about broken wire, now just guessing, maybe it pulled out of the plug? But who knows!
People have no idea how to post and give all the information with good pics that you can look at and tell WTH is going on. It blows me away. Half way through the thread they are giving info that should have been in the first post!
 

· Registered
Joined
·
60,321 Posts
Aren't turn signals supposed to flash???
 

· Registered
Joined
·
60,321 Posts
I held off from replying to fully digest your ? I'm still not 100% sure because my vehicles have blinkers not flashers, maybe someone else can help out ?
Technically, aren't they "turn indicators"?

Still...aren't turn signals\blinkers\turn indicators supposed to flash?
 

· Registered
Joined
·
7,368 Posts
Aren't turn signals supposed to flash???
Some flash faster with a burned out bulb
Technically, aren't they "turn indicators"?

Still...aren't turn signals\blinkers\turn indicators supposed to flash?
Some of them flash faster if there is a bulb burned out:hammerhead::dancing:
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top