1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Fisher Poly Caster

Discussion in 'Truck & Equipment Repair' started by Sealer People, Jan 11, 2016.

  1. Sealer People

    Sealer People Senior Member
    Messages: 210

    Hi everyone, thanks in advance for any replies.

    We were out salting last night,
    After a while I noticed that the back roller wasnt moving. & no salt coming out.
    The front roller was moving but the back wasnt.

    I unplugged the electrical plug.
    sprayed contact cleaner & put in some dye electric grease.
    After plugging it back in, i find no power at all.

    Wondering if the each of the rollers are powered together or individually
    by the plug or if Ive gotta seized roller.

    Have about half a yard of salt in it.

    Thanks for any replies.
  2. SnoFarmer

    SnoFarmer PlowSite Fanatic
    from N,E. MN
    Messages: 9,883

    Dielectric grease is a non-conductive, silicone-based grease that's designed to seal out moisture and prevent corrosion on electrical connectors. It also disrupts the flow of electrical current. Its good for lubricating and sealing the rubber parts of electrical connectors. It's commonly used in automotive spark plug wires, recreational and utility vehicles, and electrical systems in aircraft.
    It should not be applied to the contacts.

    On a battery it should only be applied after the connection is made.
    And even then it's not the best choice for this application.

    Not saying that is your issue,
    But a FYI
    Last edited: Jan 11, 2016
  3. Hysert

    Hysert PlowSite.com Addict
    Messages: 1,676

    Hey we have tornados same unit just red!! What do you mean by rollars?? Are you meaning the spinner?? If so disconnect it from the salter and try running it separate off a battery charger to eliminate the spinner motor working or not! If it still runs and the conveyer runs? Then it's either the ground on the module or the module it self has gone poopoo..
    Last edited: Jan 11, 2016
  4. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,779

    Is it a belt or chain on the track?
    How many flashes on the controler?
    The front one won't move unless it's pulled by the back one, ( that's the drive roller)you may just have a loose belt/ chain and it needs tightening.
    the harnesses fail at the plug quite often, best to fluid film them and tie them off so they don't wiggle around too much.
  5. Hysert

    Hysert PlowSite.com Addict
    Messages: 1,676

    Markus is right if it's a Gen 1
  6. Sealer People

    Sealer People Senior Member
    Messages: 210

    I took the salter into the shop yesterday.

    The repairman noticed the plug was lose, so we changed that and the power came back... (great!!,,,, not quite)

    I went out this morning to salt again, had a bit of salt left in the box from yesterday so I finished that up & after loading up again this morning (full load), the rear roller isnt moving again.

    The front drive roller is turning but the back is not & the converyor belt isnt turning forward.

    Theres just about a yard of salt in the box, im assuming theres too much weight in there and something must not be catching on that rear roller.

    This morning, it worked just fine however it had much less weight sitting in there.

    It is a first gen. polycaster. 6.5 ft

    Thanks in advance for any replies
  7. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,779

    Tighten the belt a little...

  8. Sealer People

    Sealer People Senior Member
    Messages: 210

    Thanks for the reply on tightening the belt.
    We did that and im pretty certain its fine now howevrer, we
    Just plugged her back in and theres no power.

    We took a module which corresponds with this one as we were thinking that might be the problem, however theres still no power to the unit.

    Any ideas??
    Theres power to the controler but from inside the truck nothing to the salter.
    We also put direct power to the motor and it works just fine.

    So we are stumped on this one.
    Even my repair guy is stumped.
  9. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,779

    Sounds like a module...when you say "direct power to the motor"did you disconnect the module and put it directly on the motor or power through the harness?
    Another thing is if you have turned your speed control knob too far around, the power will still light up the controller but not feed enough to the motor, wind it back.
    Last edited: Jan 15, 2016
  10. Sealer People

    Sealer People Senior Member
    Messages: 210

    We disconnected the module and powered it direct and it works.
    Theres no continuity from the new module to the salter motor apparantly.
    Could it be a faulty new module?

    The original module was a three prong but its been superceeded by the new four prong dual motor module which i believe might the cause of issue ???

    Thanks in advance

  11. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,779

    You can use the 4 prong just connect to the conveyer prong and leave the spinner prong empty...
  12. Sealer People

    Sealer People Senior Member
    Messages: 210

    Im sorry for the inconvenience but still nithing
    Our issue is that the cost of a new module, is about $900 and they won't return them
    – The module that were using now, the new one, was removed from another Salter that they had here on display to simply just test whether or not that was a module failure
    – With that said, even with a brand-new module, there is absolutely no power to the salter.
  13. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,779

    Use a test light to see where your power ends, , test the truck side harness, disconnect the mod, test the harness at mod , reconnect mod, test the mod, then test power to motor. Its pretty simple to follow, hunch is its a corroded harness, or someone didn't hook a mod up right and fried it they are supper sensitive.