1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Fisher MM2 INOP

Discussion in 'Truck & Equipment Repair' started by morethansnow, Dec 26, 2010.

  1. morethansnow

    morethansnow Junior Member
    Messages: 3

    I've got a MM2 on a 2005 2500HD Duramax with a 4 port module, I hooked up last night to beat the incoming blizzard today only to find that when I tried to operate the UDLR functions on my joystick, no movement, no whine, but my headlights dimmed and my battery meter on the dashed dropped quickly. Any suggestions, or ideas? I had the solenoid switch replaced a few days ago as it was not working. Also, 2 brand new batteries installed within the last month. Any help would be greatly appreciated.
  2. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,415

    Sounds like the motor is locked up/junk. Use a test light to confirm that you have power at the positive side of the motor when the control is activated up, left, or right. If you don't, check the relay and connections. If you do, connect jumper cables from a battery directly to power and ground on the motor. If it doesn't run, you need a motor. You could also try tapping lightly on the motor with a hammer, sometimes they just get locked up from sitting. If it runs after that, you may still want to consider replacement in the near future.
  3. morethansnow

    morethansnow Junior Member
    Messages: 3

    Since posting that thread, I have connected the truck to another MM2 plow and everything is operational. Narrowing the problem down to the plow side of things, and now seeing your suggestions I will go and try testing the motor itself. Also someone in the area mentioned the giving the poppet valves a couple good whacks, any ideas?
    Thanks again.
  4. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,415

    Not likely your issue. Check the motor.
  5. peterzereski

    peterzereski Junior Member
    from RI
    Messages: 12

    I am having a similar issue please post up what you come up with as a problem...
  6. morethansnow

    morethansnow Junior Member
    Messages: 3

    So, I ended up reconnecting the problem plow back to the truck. And to my surprise without doing anything different, the plow worked without a hitch. A few local guys told me that sometimes the motor "freezes up" and they attributed this to the fact that there is no seal, or gasket between the motor and the pump. They actually were suggesting that they had similar problems until they took apart the assembly and made their own gasket to create a seal.
    Unfortunately, my plow problem did come back 5 driveways later, forcing me to help the municipals plow the roads back to the shop to switch blades once again. I never did test the motor, but will do so as soon as this "blizzard" passes.
  7. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    hook jumper cables right to the motor. if it doesn't spin or spins sometimes and not others i would replace it.