1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Fisher MM1 Pump works, blade locked in right angle position, no lift

Discussion in 'Fisher Engineering Discussion' started by BC_Trev, Nov 30, 2011.

  1. BC_Trev

    BC_Trev Junior Member
    Messages: 2

    Looking for some help to troubleshoot my plow problem...

    Cab joystick controller activates my solenoid and the pump for Left, Right and Up functions but the plow only stays locked in the full right angle position.

    I pulled the hoses and centered the blade as I have never had it the straight position since picking it up in the summer, and when powered back up the blade again returns to full right angle. I can not get the blade to angle left, return to center or lift.

    Fluid had been filled and shoots out great when I disconnect the left cylinder... a bit messy though...

    Any help would be much appreciated as I have been trying to figure it out for over a week with no luck.

    Minute Mount 1, 9' HD Fisher blade, 2-plug system, With the SEHP Hydraulic Unit,
    Mounted on a 1994 F250 Diesel
  2. mayhem

    mayhem PlowSite.com Addict
    from Peru MA
    Messages: 1,016

    When you say this, do you mean that no matter what button you hit on the controller, it goes right or does it go to the right all by itself when you turn on the truck.

    There's another guy in the equipment repair section having a very similar problem and I went through it myself a couple years ago. In my case I had a cracked wire inside the truckside 3 pin harness. Took awhile to track it down, but eventually I was able to splice a bypass and finish the season, then I replaced the plug and the same damn thing happened to the plowside 3 pin harness. Same wire too.

    Here's the thread thats happening now and below that is the link to my old thread. Last link is to the Fisher troubleshooting giude.




    Start by plugging everything in and pop the cover off the control part on the plow and check for magnetism on all 3 solenoids when you hit the various buttons on your plow controller. The pull should be very strong and noticable...a weak magnetic pull is likely just residual magnetism on your screwdriver. In my case, the S3 solenoid wasn't firing and that causes exactly what you're describing.

    If your S3 isn't firing you can test the wiring by moving the S3 hot wire to the S2 solenoid. If your wiring is good the plow will misbehave in an entirely different way. Also get out your ohm meter and test the S3, if its good you should get 7 ohms on it.

    You need to use the guide from Fisher and be methodical about it. Start at the plow and work your way backwrds towards the truck.

    Good luck and check back to let us know how you're doing.
    Last edited: Nov 30, 2011
  3. BC_Trev

    BC_Trev Junior Member
    Messages: 2

    Thanks for your help, turned out to be a bad ground wire, once I ran a jumper from the pump ground wire to the valves all worked.

    Thanks again.