1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Fisher minute mount not moving...

Discussion in 'Commercial Snow Removal' started by shepp67_NH, Dec 5, 2003.

  1. shepp67_NH

    shepp67_NH Junior Member
    Messages: 7


    98 dodge dakota 4x4 with 98 fisher minute-mount for light-duty trucks. Plow installed when truck was bought new, by me in sept 1998.
    Came home today (12/5/2003), drove up to plow (that worked fine in june when I last moved it), locked into the pins, plugged in the 2 cables, jumped back in truck, turned on plow control, went to lift plow... nothing.

    Lights on plow come on.
    When I shut off the truck the red light on the plow controller (in the cab) stays red even in the off position, my high-beams light on my dashboard stays on (even though I didn't have high-beams on!), and if I turn on the plow controller in the cab, the power to my truck comes on (like the radio comes on) - I forgot to mention that this happens even when I take the key out of the ignition!). As soon as I disengage the 2 plow cables the controller light goes off or on depending on what position they are in (on/off).
    The only thing different since I last operated the plow - in June to move it to another location on my property - is a JET Computer module, that adds horsepower and tweaks the stock computer on the truck.

    Also, when I plugged in the plow today, teh truck was running and the lights were on...

    Any ideas as to what's going on? Is there a fuse that can go, would it cause this type of wierd behavior...?

    We have at least a foot of snow coming over the weekend... would like to think I don't have to shovel a 190' driveway... :-/

    Any assistance, ideas, etc. would be great - especially this weekend, or tonight... :-D

    Thanks in advance for any help provided... I'm going to let the truck and plow sit for a few hours and go back out and plug it all back in (with truck OFF) and see if anything changes...)


  2. shepp67_NH

    shepp67_NH Junior Member
    Messages: 7

    Additional info on problem...

    Just tried again.

    As soon as I try and move the controller stick in any direction, some thing is tripped - I hear a 'click' type noise. This is when the high-beams indicator on my dashboard goes on and stays on until I disconnect the drivers-side plug. Also the parking lights on the plow come on and stay on (even though I don't have the lights on the truck on...).

    Thanks for reading this...


    BTW - anyone from the Salem/Derry NH area that knows anyplace that will come out ot my house to fix the plow? How else can I get it fixed?
  3. sodking

    sodking Member
    Messages: 45

    Sounds like a wiring problem unfortunately. I don't know anyone who will come to you but try to jack the plow up high enough to use the safety chain to secure the plow in the up position then go to your local Fisher dealer. He will be open tomorrow. There is one I believe on Route 110 is Lowell or Dracut. I grew up down that way.
  4. shepp67_NH

    shepp67_NH Junior Member
    Messages: 7


    Thanks for the reply but, since I've had this truck since 98 with the plow I haven;t had any problems at all. No wiring has changed in my truck, other then the performance module. Could the fuse that is just below the solenoid controller (the thing in my truck to control the plow - sorry I am not a plow person by trade, just my driveway)? Is there a way to tell if the fuse is blown (I am also not too mechanical, lol).


  5. shepp67_NH

    shepp67_NH Junior Member
    Messages: 7

    One more thing


    I forgot to mention that I haven't changed or added ANY fluid to the plow since 98... I know - dumbass - could this cause this problem (not doing anything much)? I guess I'm kinda stuck till the AM, then I can maybe take a look. How hard is it to lift the blade so I can tighten the chain and take the plow for repairs?
    I don't have a jack...
    I've done nothing but plow my driveway, and then put it in the yard during off-season (it sits outside...), then come winter, jsut hook it up and use it...

    Never have had a bit of trouble with it before today...


  6. shepp67_NH

    shepp67_NH Junior Member
    Messages: 7


    c'mon guys... I don't know crap about this stuff - I just hook it up to plow my driveway every winter, then take it off when I am done...

    Looks like a trip to a service place is in order.. dang it, gonna have to shovel 12+" on a 190' driveway!

    Thanks in advance,

  7. sodking

    sodking Member
    Messages: 45

    My e-mail is sodking@comcast.net . The way you describe the proble would have to be a wiring issue. If it were fluids it would make sounds like it wants to go up, the operation would be jagged and sputter. What you describe sounds like the people who put in the CPU chip perhaps tied off wires that should not have been. basically the plows have their own CPU. When you install them you supply the plow CPU with power from the ignition side of teh harness and then run wires to the lights, and into the plow. That way when the plow is mounted and hooked up it shuts teh trucks headlights off and turns the plow headlights on. Check the wiring diagam from your origional setup against the truck now. You should also look for corrosion and bad wires on the plow itself. Frankly, it sounds like wire corrosion, grounding issue.

    Check also these links for help




    Look around that site there is a lot of info there

    The two dealers local to you would be:

    165 Merrimack Avenue
    Dracut, MA 01826

    63 Bridge Street
    Salem, MA 01970

    I have dealt with both and they are good. The best I have dealt with is :

    351 Wallis Road
    Rye, NH 03870

    hope this helps. We shouldn't get too much by morning maybe 2" but I would get there as soon as they open. You should also expect that since you are not a professional they may service a pro first.

    Erik Sweetser
  8. sodking

    sodking Member
    Messages: 45

    Sorry my typing is bad tonight, my daughter is having a slumber party for her 9th
  9. sodking

    sodking Member
    Messages: 45

    Sorry the Fisher Dealer near you would be:

    Londonderry, NH 03053

    They are the best in your area an closer to Derry that the Dracut one. They are near the old Manchester Racquetball Club.
  10. shepp67_NH

    shepp67_NH Junior Member
    Messages: 7

    Thanks bro...

    Hey sod,

    Thanks for the info. I called the Londederry joint today, not open :-/. I've resigned myself to the fact that I am shoveling this storm. I'll call then on Monday and see what's up. I also thought about pulling the chip (it's not a CPU that any 'wiring' had to be done. It's an in-line module that sits between the PCM (CPU) and the engine (basically over-riding the dakota stock PCM (power control module)). So nothing, and I mean nothing in the way of wiring was touched - in fact I installed the module in about 5 min, disconnect battery, unplug black connector from PCM, plug JET module into PCM, plug wire that was in PCM into the JET module, re-connect battery, start truck, vroom, vroom, 15-20 horse to the rear wheels, lol.

    I think I'm gonna remove the JET module and see what happens...

    Will reply back either way - in case this JET moduel is dorking with my plow, others in the future can search for it here and know the scoop.



    BTW - I am a professional, just not a plow professional - lol - software engineer.
  11. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Check all battery connections for good, clean ,tight connections, check for corroded wires. What happens if you jumper the motor relay? If motor runs, replace relay. If motor doesnt run, check for 12 volts at the motor, if 12 volts, motor is more than likely bad. You should be able ot remove the end cap on the end of the motor can check for worn out brushes which is probably causing an internal short.
  12. shepp67_NH

    shepp67_NH Junior Member
    Messages: 7


    OK, I called the londonderry shop, the service person said to get some dielectric(sp) grease. Scored some, put all over connections to plow (plugs) and loosened nuts on soleniod, greased them up too (bolt, connectors). Pulled up, plugged in, fired up truck, turned on controller and - YES! The plow is back on-line for tomorrow nights blast!
    BTW - I removed the JET module and the only change was the issue went from one 'click' then nothing (except the wierd stuff described in the earlier threads), to the constant 'clicking' from the soleniod.

    JET chip is not and was not the problem, but did mask the issue.

    Thanks to those who contributed to this thread!


  13. sodking

    sodking Member
    Messages: 45

    Your welcome Joel...looks like you fixed it just in time for tomorrows snow!!!