1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

First generation Fisher electric problem.

Discussion in 'Fisher Engineering Discussion' started by Blazin, Feb 10, 2008.

  1. Blazin

    Blazin Senior Member
    Messages: 185

    I have a problem with my first generation electric Fisher unit. I bought the truck a few weeks ago. When I got it the joy stick was backward, to raise it you had to push down, visa versa. Same with angle, left was right, right was left? Looked it over, opened up the controller everything is soldered to a circuit board. So I just flipped it upside down on the bracket. Second time out it started getting slow and was intermittently not angling right. Next day I drained it, pulled the motor, cleaned out the reservoir, cleaned the screen. Refilled the reservoir ( with blue fluid ), still had the same intermittent problem. Pulled the three coils, pulled the valves, cleaned them with brake clean. They are all free, and seem to be operating correctly. I have noticed over the last few storms that the more I angle it the more the problem happens ( the hotter the fluid? ). If you switch it back and forth up, right, up, right, up, right, as fast as you can it will eventually angle right a little bit at a time. Then the next time or two times later it will work fine. Now it is starting to happen in the left angle and sometimes even the raise position. When its not working you don't hear the motor running.
    Not sure if the motor not running is electrical, or if the lack of valve presure or presence of valve presure would make it not run?
    My other thought is the coils on the valve body are week?
    My third thought is it is in the valves that thread into the valve body are sticking or bypassing?
    If they are stuck open will that make the motor not run?
    I am leaning to wards the micro switches inside the controller are getting hot?
    I have looked the wire harness over at least ten times, it is all in great shape. Am 99.9% sure that there is no problems there.
    Has anyone had this issue or one similar to it? Any ideas would be great.
    One other thing is how do you adjust the push back presure?
    Thanks Harold.
    Last edited: Feb 10, 2008
  2. Buster F

    Buster F Senior Member
    Messages: 208

    Hey Harold, sounds to me like could possibly have a weak battery/ charging system situation. Are you headlights getting real dim when these problems occur? You may want to get your battery load tested and take a look at your alternator output. Also, take a good look at your grounds - many times its the simple stuff that has us scratching our heads. Good luck, Roy
  3. Blazin

    Blazin Senior Member
    Messages: 185

    The battery is almost brand new, a few months in my old truck. It is a heavy duty 1000 CCA The head lights do dim a little bit but not what I would consider a huge draw. The gage on the dash is reading well over 13 volts. I neglected to mention in the first post, I did clean all my connections and even remounted the solenoid under the hood when I changed the fluid. It was allot worse today so I am definitely going to go over the whole thing tomorrow. I will recheck the connections and put a multi meter to it.
  4. Greybeard

    Greybeard Member
    from MA
    Messages: 35

    This may sound like a dumb question, but are you sure all your hoses connected correctly? I had an engine swap done years ago on a truck with the same system, and they swapped connections on the hoses when they put it back together.
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    You mentioned that when it's not working the motor doesn't run, but does the under hood solenoid still click?

    If it doesn't. then the problem is either the controller itself, the solenoid itself, or a poor connection at the controller plug under the dash or on the solenoid.

    If it does still click, then it could be the solenoid, or a dead spot in the pump motor, or a poor cable connection between the battery and the pump motor.

    Need to do more diagnosis...but I can tell you so far that if the motor isn't running, then it's not a valve, fluid or internal pump problem.
  6. Blazin

    Blazin Senior Member
    Messages: 185

    The solenoid or motor relay as Fisher calls it was replaced by the previous owner shortly before I bought the truck. Today I used a remote starter switch and when it was not working connected the two alligator clips to the large posts on the relay. With someone else holding the joystick in one of the three positions I could make it work with the remote starter switch. This led me to think the relay / solenoid was bad. I bought a new one SAM replacement. With the new one installed nothing worked all the time. Put the old one back in now its back to intermittently not working. I am leaning more and more to the controller being bad. Special order through the New Hampshire Fisher guru, $215. I found one brand new in Gardiner Maine for $100. Problem is its an old codger and he dosn't do credit cards. So I suggested COD. His answer was he didn't know how to ship it. I talked him into getting his wife to go to the post office and figure it out. Thats next on the list, I hope this solves the problem.
  7. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If it didn't work at all with the new solenoid, it sounds like you had/have the incorrect solenoid.

    If you want to test to see if the problem is in the controller, or in the solenoid:

    Use your remote jumper switch to actually trip the solenoid (not bypass it like you did). Clip one lead on the pos batt post and clip the other lead on the small post on the solenoid with the small brown/red wire. If it still doesn't click the solenoid every time you operate the remote switch then either the solenoid is bad or the orange/black ground wire on the other small post on the solenoid isn't making a good connection. Thus the solenoid wont have good ground.

    If it works every time with the remote, then theirs a good chance it is a bad controller or a poor connection at the dash plug.
  8. Blazin

    Blazin Senior Member
    Messages: 185

    Its got a good ground as I took a grinder to the inner fender where it bolts down to clean it up. Back when the problem first started happening. Its is the correct solenoid as it is identical to the one that was on the floor when i bought the truck. The one that is on there is a little bit different, but its the one that works sometimes! Going to mess with it some more today. Change the fluid again too as it has become real slow. Last time that happened the little filter under the motor was all crudded up. Thanks for the input, i will keep everyone posted, Harold.
  9. Blazin

    Blazin Senior Member
    Messages: 185

    Well I put the new joy stick controler in today. Went out and cleaned up most of my driveways and a few little seasonals that i left yesterday. Had no problems at all.