engine won't start...

quarter

Junior Member
I just got another vehicle - a 95 G30 with 5.7L TBI. 94000 miles, seems to be in good shape overall. As I drove it home, I stopped for a break and had trouble getting it started again. It did start, but the check engine light came on and stayed on the rest of the trip. I plugged in a code reader & got 33 - map sensor voltage high and 87 (I think) which said problem with EEPROM or EPROM or something. Engine felt okay as I drove rest of the way home, but would not start after I cut it off in the driveway. I replaced the map sensor. Distributor is not loose. I've got sparks & fuel... I can't get it to fire up, though. Plugs look fine, wires have reasonable resistance. Two suggestions have been made to me; I thought I'd ask for more advice before proceeding: timing chain slipped or computer is "shot". I'm quite open to other suggestions. Any and all help is appreciated.

Roger
 

plowking35

2000 Club Member
Location
SE CT
Try disconnecting the puter for 15 min to clear it, amd see if it starts after that. then have a shop read the puter, that will tell what went wrong.
Dino
 

John DiMartino

PlowSite.com Veteran
Location
Walden,NY
It sounds like you need help from a professional-let us know what it is,My guess is the computer is bad-low or high reference voltage to Map sensor -its supposed to be 5 volts-if its higher or lower-the truck wont run right.Computer controls voltage to sensors-just my guess.
 
Sounds like the PROM went bad.Common problem on those.Will also cause the MAP code you listed as well.It's a cheap and easy fix.Pull out the computer (usually under or behind drivers seat on the vans),and you will find a small metal cover on it.Take it off,and underneath is a small "chip".Disconnect,the battery,pull it out,and take it to your dealer,and get a new one.They are cheap,usually about $35.00.They are very specific to your vehicle,and the dealer will match it with the code numbers on the old one.You will get an "updated" PROM,which will include programmed updates to make the vehicle run better.It could also be the ECM,which is the actual computer box itself,but 9 times out of 10 it is just the PROM.
 
OP
Q

quarter

Junior Member
update - the dealer, after 5 days of "it'll be in tomorrow at 3", finally got the PROM chip in, at $45+. Motor won't start, still. With the ew chip in, I checked for the compression stroke vs where the rotor button was for a few cylinders, and it seems like the spark is firing at the correct time. When fuel, spark, and compression all seem reasonable, can the computer really prevent it from firing up? I've begun to suspect fuel contamination - maybe water or something and enough of it that it's causing the trouble. I'll investigate this later today or tomorrow. Any other oddball suggestions?
 

plowjockey

PlowSite.com Sponsor
Location
Dayton, Ohio USA
No oddball sugestion but a way to check for sure is to hook up a timing light on the #1 plug wire and have someone crank it over to make sure that you have spark. This will tell you if the module in the distributor or possibly the pick-up in the dist. are not working.

Bruce

P.S. I'm guessing that you have already checked to be sure that your fuel pump is putting out pressure.
 

John DiMartino

PlowSite.com Veteran
Location
Walden,NY
I had a truck once that had fuel ,spark and compression,timing was correct,still wouldnt start.I went nuts with this thing,sometimes you need to step back and rethink everything,about what an engine needs.After a few minutes it hit me.The catalytic convertor was plugged solid,I mean totally blocked to the point where the engine wouldnt start.I loosened the Y-pipe and it fired right up.Im embarrassed to say this,but I wasted a good day on this truck,rechecking everything,and trying to get it running.So yes-it can have fuel.spark and compression,and be in time and still not start,the engine is still an air pump and if air cant get out,none will enter nad it wont start.
 

plowjockey

PlowSite.com Sponsor
Location
Dayton, Ohio USA
John
Very good point. I had completely forgotten about the old potato in the exhaust trick.

(disclaimer: KIDS DO NOT TRY THIS AT HOME)!! This could cause projectile mashed potatoes.


Bruce
 

mike reeh

Senior Member
John thats a good one.. what finally tipped you off that it might be the converter? just a hunch? seems like it would sound funny during cranking, or something..

mike
 
OP
Q

quarter

Junior Member
So it does seem that the converter is the culprit. It fired right up after I loosened the u-clamp - I didn't even get the pipe all the way off. Just enough of an air leak to get it started, then the engine has enough force to push air through.

I must admit, I was surprised. Every other time I've had a problematic converter the car had wierd power problems as the symptom. I didn't feel any of that in this situation. Can a cat be tested? When you say plugged solid, do you mean to the point of visibility? I've not seen that before.

Now I can get to the rest of the nused vehicle cleanup that needs to be done to it. I apprecieate the help.

Roger
 

John DiMartino

PlowSite.com Veteran
Location
Walden,NY
The Cat needs to be replaced,ASAP.Dont bypasss it,they arent that expensive anymore,so go to a muffler shop,or get a direct fit,and install it yourself.I found mine by racking my brain,and the tiny hiss i heard if someone els cranked it,it still cranked about the same as if it want plugged up.
 

Top Forums

Similar threads

Similar threads

Top