1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Electrical Problems E-47 please help!!

Discussion in 'Truck & Equipment Repair' started by kcurt48, Dec 30, 2007.

  1. kcurt48

    kcurt48 Junior Member
    Messages: 3

    I have an E-47 meyer's plow with the 2 individual switches and right now I am completly baffled. The problem is that the plow will sometime raise and the right angle will work and down will only work if I push left angle on the swicth but left angle never works, and sometimes the motor wont turn on at all, and other times when I try to move the blade in anyway the light in the cab comes on instead. In my trouble shooting I replaced the harness and the solenoid and still the same thing. Then I disconnected the red, black, and green wires from the harness and tested manually one by one straight from the battery and the plow worked beautifully. So this makes me believe that the problem is some where between the solenoid and the swtiches. Any ideas at all please tell
  2. Young Pup

    Young Pup PlowSite Fanatic
    Messages: 5,522

    How about the connections on the pump itself for the wiring. They could have come loose. Other than than I am not sure what to tell you.
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Are you using a genuine Meyer control harness that the plug on the back of the switch panel is a singe molded plug?

    How about actual "Meyer style" 5 terminal switches...

    What light are you saying "comes on in the cab"?

    For it to drop when the angle left function is pushed, something is definitely wrong.
  4. kcurt48

    kcurt48 Junior Member
    Messages: 3

    I just figured out that its not the switches because I ran the harness bypassing the solenoid and everything worked beautifully. I know its not the solenoid itself because I just replace it so maybe the solenoid isnt grounded or the hot lead going to the solenoid is fried? The Interior light in the cab didnt come on ether when I bypassed the solenoid
    Last edited: Dec 31, 2007