1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E60 problem.....no up

Discussion in 'Meyer / Diamond Products Discussion' started by tmurphyjd, Dec 8, 2011.

  1. tmurphyjd

    tmurphyjd Junior Member
    Messages: 1

    Ok I started today by removing pump to change fluid. Keep in mind worked perfect before removal. I drained fluid cleaned out filters and filled pump, put it back on the truck and when i hit the up button on the touch pad the lights go out and red light goes on. I don't think the motor even kicks in..any help???
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    Simple things first.

    did you get all the wiring properly attached when you reinstalled the pump?

    did you try it before you changed the fluids, everything worked fine?

    if not did you have a new battery installed in the truck? Sometimes when they install new batteries they forget to attach the plow's power wire (or ground or both:dizzy:)

    Are you getting 12 volts to the 12 volt motor solenoid?

    Are you getting 12 volts to the white wire on 12 volt motor solenoid?

    Did you pinch a wire in the removal/servicing/installation process?