1. dirtmandan2

    dirtmandan2 Senior Member
    Messages: 275

    Ive burnt up two pumps in the last week on the same plow... when I replaced the the motor i also replaced the pump... as it turned out the new pump was bad... the gears were rubbing on the spacer plate and it turned really hard... put on a new pump and it worked great for about 3 hours, then smoked the motor... replaced the motor again and rigt now its working fine ( afraid to go use it ) angling the motor sounds great, while raising though it sounds like its working too hard... what am I missing???
     
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,985

    S.A.M. parts or Meyer OEM?
     
  3. OP
    OP
    dirtmandan2

    dirtmandan2 Senior Member
    Messages: 275

    the pump that was junk was a sam ( brand new part ) replaced w/ a meyer pump... the motors are rebuilt...
     
  4. OP
    OP
    dirtmandan2

    dirtmandan2 Senior Member
    Messages: 275

    need some help here guys!!
     
  5. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,985

    What kind of pressure is it producing?
     
  6. OP
    OP
    dirtmandan2

    dirtmandan2 Senior Member
    Messages: 275

    i dont know i went out to the meyer shop and THEY DONT HAVDE A GAUGE so monday i will have to see if i can find one... hopefully it doesnt burn up tomorrow night supposed to get 6 to 10 inches!!! putting wings on one of the plows tomorrow so hopefully that;ll help me out if the motor does go out