1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E47 won't go up w/lightning bolts

Discussion in 'Meyer / Diamond Products Discussion' started by squeefoo, Nov 26, 2008.

  1. squeefoo

    squeefoo Junior Member
    Messages: 4

    First of all Hi !
    Second. Here is the problem.
    I was in a hurry to put the plow back on my truck for the season and I accidently reversed the ground and power lead. Put them back right. Now it won't go up. Pump motor spins fine.
    I've checked the fluid (change it every year), did a magnetic test on the A and B solenoids and the A was very weak and nothing on the B. So I bought two new ones and installed them after taking out the valves and making sure everything was clean.

    Now when I hit the up switch I have sparks jumping from the ram to the lift arm. :dizzy: Didn't do it before I put the new solenoids on.
    The motor spins fine while this happens, but still no up on the lift arm. I thought it might be a bad ground but the cable is clean on both ends and no resistance between the neg. battery connection and the ground bolt on the back.

    Why always me? :rolleyes:

    Thanks for any help. ...and I'm sure my customers will thank you too. :salute:

    PS: All the connectors are hooked up properly and have power appropriate to the switch position.
    The unit was stored indoors for the summer in an upright postion and worked great when I put it away...
    Last edited: Nov 26, 2008
  2. tom_mccauley

    tom_mccauley Senior Member
    Messages: 465

    you said the motor spins fine, is that when you hit the button or turning by hand?
  3. squeefoo

    squeefoo Junior Member
    Messages: 4

    When I move the toggle up -solenoid clicks, motor spins, -sparks ensue.

    I didn't take the motor apart yet since it was pretty late, coming apart today sometime.

    The sparks jump from the tops of the studs going down through the reservoir to the lift arm.
  4. tom_mccauley

    tom_mccauley Senior Member
    Messages: 465

    sounds like pump gear is worn/stuck, that is where I would look first!:drinkup::drinkup:
  5. squeefoo

    squeefoo Junior Member
    Messages: 4

    Well the motor/armature/brushes/pump/gears seem fine, just a little bit of gray sludge and some corrosion here and there. It may be the corrosion at the bottom of the motor case not letting it ground well enough.

    Cover me, I'm going in deeper. :D
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Uhh yea, if you've got sparks flying I'd call that a definite. :D

    A good way to ruin the gear pump as well. ;)
  7. squeefoo

    squeefoo Junior Member
    Messages: 4

    Thanks for the comfirmation.

    O- ring kit Mon. -after a lot of parts washer, scraping and wire wheel time, we'll see if the thing decides to work right and go up.

    Have a nice T-Day!
  8. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    Check the grounds at the battery and the ground cable itself. good grounds are key