1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E47 Motor Solenoid Help

Discussion in 'Meyer / Diamond Products Discussion' started by jumpstart, Dec 21, 2009.

  1. jumpstart

    jumpstart Junior Member
    Messages: 6

    After our disaster with the valves, that you guys helped us with in this thread

    We did notice that our seal kit came with an extra seal per valve, that was not shown in the diagram or on the valve when we took them out. We removed those seals that just sat down in and really didn't do anything. Reinstalled the likely defective valves.

    We tried to raise the arm. Nothing. Doesn't even sound like the motor is spinning anymore. So it's like WTF, from one thing to another to another. We hear a "click" under the hood, but the motor doesn't seem to want to turn.

    I check for voltage at the solenoid an got 12V. But at the motor, with the switch to raise, I get no voltage.

    So I read in another thread I can bypass the system and hookup jumper cables to the motor to see if it spins. Tried that, and it made a little bit of noise for a second, but did nothing. The connection to the positive terminal on the motor is quite rusty, so I can't tell if I am getting a good bite on it or not. Nor can we get it apart.

    Am I missing something? Anyone have any other troubleshooting ideas? I mean we plowed two long driveways fine with this rig last week. Thanks
  2. poncho62

    poncho62 Senior Member
    Messages: 431

    Clean up that terminal on the motor and try again.....Also make sure you have a good ground with your other jumper cable....Ground it right to the motor.

    You can also check the other big terminal on the solenoid for voltage...It should have 12 volts coming out when you are on lift.

    Sounds like all your terminals just need a good cleaning.
  3. jumpstart

    jumpstart Junior Member
    Messages: 6

    Ok, have done that, and we have 12V for sure to the top nut on the motor. But nothing is moving, it makes no sound at all. The solenoid clicks, and we tested that too, and that is working properly. It send 12V from one side to the other when the raise is pushed.

    Damn, could that motor be burned out? Just like that with no warning? Is changing them a bear to mess with, looks like two bolts at the top and that's that? Thanks
    Last edited: Dec 21, 2009
  4. poncho62

    poncho62 Senior Member
    Messages: 431

    Seems like it........something is amiss inside the motor.......