1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E 60 Won't Raise

Discussion in 'Meyer / Diamond Products Discussion' started by odd1or2even, Feb 5, 2009.

  1. odd1or2even

    odd1or2even Senior Member
    Messages: 117

    After a night of problems my one truck's plow stopped working. The pump is an E-60. As I was at a clients driveway I had an error on the touch pad. So I got out and tried to figure out the problem. At the time, I saw a good amount of red snow on the ground (Red ATF fluid). Then I found that my male connector was loose (on the block) and was letting the fluid out. I ended up tightening it, and then refilling the fluid and it worked fine.

    Next problem was when I was at a parking lot. I was plowing fine, then all of a sudden the plow would not raise. Then after trying it a few times it would raise it but then eventually it wouldn't work at ALL when I pressed the up button. It works fine left to right, but it just doesn't raise.

    What I did was take off the 3 leads and with a jumper battery I checked the magnetism on all coils and I get little sparks from the negative. I hear the magnets click or lift so I know they work except for the black wire. I was getting a little spark but I wasn't hearing a click. I had a spare black coil and valve but it was a smaller threads/post on top then the one that was on my E60. The original was about 3/8's, the used one was about 1/8th. I checked the spare and heard it click so I put in a working one. When I pulled the black coil, and then the valve the fluid started to flow out so I quickly put the spare in. But when I hand tightened the valve, I checked, and this time it didn't click so I am lost. Any help?

  2. odd1or2even

    odd1or2even Senior Member
    Messages: 117

    Any thought on anyone? It turns left and right, but does not go up. I went to Meyers diagnostic website, and followed the directions, but the black coil has electricity, but I don't hear it click. Could just the valve be stuck and that's why I don't hear it? I had a replacement black valve and coil and it worked prior to going in (could hear and see the click), but when I pulled the old valve out, oil started to raise out of the hole so I quickly put the undersized unit in that works. But when I test it, I don't hear it click.... so I don't know. Any help would be great... Thanks
  3. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    First, get rid of the ATF. Meyer Pumps do not like ATF, it's to thick. Doing so will speed the pump up and use less power.

    As for the lack of lifting If you have pump pressure, either your "B" solenoid/check valve, control/harness or the lift packing's shot. Sounds like you should strip it, clean it well and throw a partial seal kit in it.