1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E-60....No lift or Lower.....Ideas for a newbie??

Discussion in 'Meyer / Diamond Products Discussion' started by MI_Mangler, Dec 10, 2011.

  1. MI_Mangler

    MI_Mangler Junior Member
    Messages: 2

    I hope some of you pros can help this newbie. As my signature shows, I have a E-60 pump, with a Iskra 2 terminal motor. I have changed the fluid out, replaced the filters, & bleed the system by loosening the ram connections (alternately) to let them leak while moving the blade left to right. This is the same procedure that I used last (my first) season. I then tried the lift & lower & just get the red trip light. I have 2 touch pads & get the same result with them both. The plow will start to go left before the trip when I touch the raise button. I changed the A & B coil with new A & B coil assemblies. I left the C coil alone because it moves left to right just fine. I have tried this with the plow chains hooked up (under load) & with the chains unhooked. Any new ideas/suggestions would be greatly appreciated!
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    Check your grounds and chase the wiring looking for a fray, broken or pinched wire in the control harness.
  3. MI_Mangler

    MI_Mangler Junior Member
    Messages: 2

    Thanks for your reply basher. I plan on checking out the wiring for the lift/lower functions tomorrow.
  4. TomsSnowPlowING

    TomsSnowPlowING Senior Member
    Messages: 253

    I am E60 also Please keep us posted