1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E-47 wont lift - stuck piston?

Discussion in 'Meyer / Diamond Products Discussion' started by eriklane, Jan 8, 2011.

  1. eriklane

    eriklane Member
    Messages: 75

    I've posted before. Old E-47 unit on a free truck that sat 7 yrs. Replaced A,B solenoids and B valve. All click nicely when powered. Removed motor and scrubbed it with a wire brush to remove some minor greenish/brownish coloration on the stator, new brush/cap, good connections everywhere, full of fluid. Replaced most seals inside the unit. Will not lift. Motor runs smoothly.

    Down to this-there is a piston-I cannot get it out and it doesn't move, it's ball bearing moves freely. Can I tap the ballbearing side to get the piston out? Should it move freely? If so, how can I get it out-my magnet tool wont pull it out.

    I cannot remove my left/right block - the allen nuts are simply frozen and my wrench, even with a pipe, will not move them. This system did work a few times up and down, left right...
  2. cmo18

    cmo18 Senior Member
    Messages: 815

    What does the inside cylinder look like?
  3. eriklane

    eriklane Member
    Messages: 75

    Tear down

    Full tear down today after realizing it wasn't gonna get done on the truck. Put it in the vise, took all valves out to see if any ice or grime present-none. I did get the ball on the underside of the piston out, and then using a heavy nail, tapped on the bottom of the piston-it finally popped out and I did see some rust, not much, but gently sanded it and cleaned it all-now it moves freely. Decided I had to open the top and take the guts out. Poured out the fluid and heard globs coming out...judas. Took the big sleeve off and the piston etc, and noticed a lot of gunk...Full clean job. Some ice, but not much, one blob of ice tho, size of pencil eraser, 1" long or so...Tons of grit...Cleaned entirely, my new fluid 2 mos ago, I put thru cheesecloth and got a LOT of gunk...Reassembled it all and put fluid in, still will not lift. Pump runs great...

  4. mrascoe

    mrascoe Junior Member
    Messages: 17

    will it lift freely when you pull it up by hand?
  5. eriklane

    eriklane Member
    Messages: 75

    yes, the shaft does lift if I pull on it.
  6. eriklane

    eriklane Member
    Messages: 75

    E47 problems

    Today, after letting it sit in the warm garage all night, it still doesn't lift, so, if there was ice in the unit it would have melted overnight and worked today, I'd suspect.

    So, what I dont' know anything about is 2 things. There's a large nut to the right of the C solenoid that I took off but under that is another stub sticking out with a small screw in it. That comes out. But, I don't know what the rest of that is/does...Also, behind the pump is the port where you can check the pressure...I may have to take that out and see whats up there-could it be gunked up too? I don't have a pressure gauge.
  7. eriklane

    eriklane Member
    Messages: 75

    Figuring it out finally

    With the pump off, I twist the little shaft sticking out of the base and noticed leakage at the back of the unit where the coupler to the lower arm is...Now I know why no pressure can build up-duh!