1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E-47 Pump Issues

Discussion in 'Meyer / Diamond Products Discussion' started by JasonRG, Dec 7, 2010.

  1. JasonRG

    JasonRG Junior Member
    from Ohio
    Messages: 8

    I have a setup on a 1996 GMC Sierra using an E-47 pump. All was working well a week or so ago, but is now not functioning correctly. I started the truck this morning and was able to lift the plow, but then tried to angle it and it didn't move. I lowered it back down and checked my hoses and all appeared to be OK. I tried lifting again and it wouldn't lift it. Could this be caused by a low hydraulic oil level?

    Do I need a special type of fluid for the pump, or is it just a typical hydraulic fluid? Any help would be greatly appreciated.


  2. geer hed

    geer hed Senior Member
    Messages: 275

    Start off with checking the oil in the pump. Use meyer or equivilant fluid, not regular hydro fluid. The meyers fluid has additives in it to fight water and to keep the fluid from thickening when it gets cold.
  3. aron7676

    aron7676 Junior Member
    Messages: 21

    I am having a similar problem. I tried to angle the blade, and it would move to the left, but would not move right... when I hit the right button, it went left. Its not an electrical problem, because no wires have been moved since last year, and the plow wasn't removed.
  4. .5racer

    .5racer Senior Member
    Messages: 132

    Check all ground conections , a little dew or frost will rust and mess up a good ground. Start there then check coils for mag with screwdriver.
  5. FrFtr28

    FrFtr28 Member
    Messages: 39

    It might be your quick connects. Connect your two cylinders together with one hose, then try and angle the blade manually. If the blade doesn't move, than it's your quick connects.
  6. geer hed

    geer hed Senior Member
    Messages: 275

    OK your having a problem with your C-valve. Thats the one with black wire. First check it for magnetism. Simply have some one activate the switch and hold something metal ie: screwdriver, small wrench, to the center of the stud that holds the celinoid on. If it doesn't become magnetic when the switch is activated the coil is bad. If it does become magnetic take the coil off and remove the valve, look very closely at each O-ring and make sure they are in perfect shape, even a little tiny nick can cause trouble. Also while it's out take a tiny philips head screwdriver and from the bottom of the valve insert the screwdriver and push. there is a small spring loaded ball inside that you should feel move, if it doesn't you can try spraying some WD-40 or what ever type spray you have and try pushing again, If it's working properly you shouldn't have to push on it very hard to get the ball to move. If you can't get that ball to move you need a new C-valve.
  7. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    C coil/valve is green not black. Black is the A valve (lower).

    Or much more commonly it's not receiving power due to a faulty controller or most commonly a poor connection between the controller and the coil.
  8. geer hed

    geer hed Senior Member
    Messages: 275

    B&B Thank you for correcting me on the wire color, I had a brain fart. it is the green.
  9. JasonRG

    JasonRG Junior Member
    from Ohio
    Messages: 8

    Checked each of the coils and they all seem good. Checked the fluid level and it was low so I added some of the Meyer M-1 Fluid and it is working well now. Thank you everyone for your replies!
  10. Trammell

    Trammell Junior Member
    Messages: 1


    my plow go left and right but wont go up and down can any body help i also got hydrolic fluid coming out pressure relief valve