1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

DIY v plow install Electrical Issue Help!

Discussion in 'Boss Plows Discussion' started by generalee31184, Aug 20, 2012.

  1. generalee31184

    generalee31184 Junior Member
    Messages: 19

    So I finished installing the electrical harness today in my 2011 F350 6.7. I am pretty sure I have it all hooked up properly. So I said here goes nothing the truth lies in trying to actually hook up the plow. Entire setup up is a couple years old, just bought it used harness and all. So I plug it in, push the smarthitch button to connect it and I hear a pump running and nothing moving, so I let go of the button and it just kept running. I had to physically unplug it to get it to stop. So I replugged it in and went to controler and pushed a button or two and it did the same thing again. Nothing would move just hear the pump running. So I backed away and went back in the garage testing every pin on the truck side with all appearing to test out ok. I was thinking sticking solenoid but without it plugged into plow it tested out ok. I know the plow side works fine and I just brought it home on my buddies truck a couple weeks ago and it worked just fine. Any ideas?
  2. BOSS_JG

    BOSS_JG Sponsor
    Messages: 207

    I ran your question by the BOSS Technical Services department. They suggested giving them a call to troubleshoot. They can be reached directly at 906.776.3500. Jamie or Andy will be happy to help you out!
  3. generalee31184

    generalee31184 Junior Member
    Messages: 19

    :gunsfiring:Thanks for that reply and I may be making that call tomorrow. Here is where I stand as of today, I replaced the main solenoid and now the plow will motor properly with smarthitch switch BUT it still will not mount itself up to the truck. I pulled the smarthitch solenoid out of the head unit and cleaned it/checked it. I will say it had some crud on the the screen and I believed it was stuck a bit. I freed it up and put it back in along with pulling other to check. put back to together and still will not mount up! The motor runs but will not suck up to truck. SO I then manually pushed the head unit up to the truck mounting the plow to truck. I then was able to raise the plow and use all functions of the plow. So I set it down unhooked, and it seemed that the smarthitch worked to unmount the plow. I then tried remounting and still will not mount itself. IDK where to go from here. I checked the magnatism on that smarthitch solenoid and seemed fine also. The one other issue I have noticed today is that when ever I hit the S/H switch or any switch on the controler it is making the parking lights on the plow come on dim while pushing any buttons. The lights all work properly in themselves. Stopped by boss dealer today and of course they said bring it over. I can get it on the truck at least and over there if I have to. Im gona give that number a call tomorrow.
  4. kurtandshan

    kurtandshan Senior Member
    Messages: 323

    They are great. Speak in terms we all can understand and trully WANT to help fix the problem. They are not just sitting at a desk. They are in the R&D shop with headsets and cordless phones so they utilize everything in the shop to help you diagnose a problem.
    Last edited: Aug 22, 2012