1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Curtis - Nothing works

Discussion in 'SNO-PRO PLOW AND ACCESSORIES by Curtis' started by syberdogpa, Jan 10, 2009.

  1. syberdogpa

    syberdogpa Junior Member
    Messages: 5

    Tried putting foot down - wont go - tried lifting plow -up ,down,left,right - nothing works - selonoid works - tried playing with wiring -- still nothing - LIGHTS work - just fine -minus 11 and it works - +24 NOTHING works -- - is everyone having problems with controller ( or pump,?) or is it just my plow that wont work when I need it too? - got home tonight tried to get it to work -- small amount of snow and - AGAIN it wont work -- yesterday - NO SNOW - and it worked - swear its haunted -- Any ideas whats going on with it ?
  2. Turbodiesel

    Turbodiesel Senior Member
    Messages: 428

    installer ? ground wires?
  3. syberdogpa

    syberdogpa Junior Member
    Messages: 5

    checked all leads -- grounds good -- installed 3 yrs ago - this just started up ( this season ) some times its dead other times it works great --Dealer installed
  4. Turbodiesel

    Turbodiesel Senior Member
    Messages: 428

    Controller , fuses ,check harness & grounds again. The problem is usually & right in front of your face lol
  5. bow2no1

    bow2no1 Senior Member
    Messages: 338

    i bet it's the main plug from the plow to the truck... to you keep it well lubed?
    clean all the prongs and holes with small wire brush of some sort. get all the old grease out of it.

    then fill it with dielectric grease
    there was a problem with them and Curtis makes a new style to replace the old ones
  6. zztarg

    zztarg Member
    Messages: 68

    Check that power is getting to the coils that operate the valves. That power comes from the U/D L/R switches. If power is not getting to the switch, or from the switch to the plow, the vales won't work.

    At the same time power goes to the valves, the solenoid is enabled. If the solenoid coil is getting power (small wires, not the big one going to the pump) then power is at least getting to the switches.

    If the solenoid is good (power to pump when switch is activated), then the problem is probably the connector. Check for power at the truck side connector. If that's good, and you have continuity between the plow side connector and the coils on the plow, then it's likely you've got a loose connection at the connector.
  7. ondirtymax

    ondirtymax Member
    Messages: 70

    Installed 3yrs ago? Do you have one plug on your wiring harness (square with one side angled)? If so, I'll put money on it being the culprit. That is the old style connector and can be quite tempermental. I have the same setup as that and it requires constant attention. If you have the new style, ( one square rubber connector and a seperate connection for main power and ground) it could still be the culprit. Make sure you have no green death going on in there and make sure it is well lubed with dielectric grease. GOOD LUCK!
  8. gkm

    gkm Senior Member
    Messages: 305

    check the plug may need to wire brush it out make sure nothing is in there than lube it up
    good luck

    the Guys at F/X auto in Lebanon,nj can fix it for you. 908-534-3120:drinkup:
  9. picknick15

    picknick15 Junior Member
    Messages: 26

    sounds like exactly what mine was check to see if you are getting 12 volts to the pump and if you are it is probably the leads in the motor. Needs to be replaced. This is exactly what mine was doing and it was the leads in the motor and I ended up getting a whole new motor. The factory wants 400 for the two post motor. Here is one on ebay with a single post that I used on mine. Works just fine. and for alot less.