Chevy S-10 stalling

TJLC

Junior Member
My truck is an 86 S-10 2.8v6. Recently it has been stalling as I come to a stop. It seems to run ok except when I come to a stop and idle,sometimes it will stall. It starts up ok but then stalls again at the next stop. Any thoughts?
 

John DiMartino

PlowSite.com Veteran
Location
Walden,NY
Clean the TBI housing,and pull and clean the IAC control motor,it has a bog hex head on it and 4 wires going to it,its mounted on the TBI unit,sometimes they carbon up and the truck will idle funny.Also check all the vacuum lines while your at it.Good luck.
 

gitzenlandscape

Junior Member
I don't mean to sound ignorant, but have you checked the oil level? When I was in High School I had a car that started doing the exact same thing. After I checked everything I noticed the oil level wasn't even on the dipstick! I added a couple quarts of oil and everything was fine.
 

Fierospeeder

Junior Member
If its not running right for you, i had a similiar problem with a 2.8. It was the ignition module that went out on it. Only the 4 out of 6 cylinders were firing.

One way to test for this is to have a timing light and hook it up to each wire and see if each one is emitting a light.

When you pull the IAC to clean it, make sure you dont loosen the cone because the spring will shoot out, making it hard to find.
 
OP
T

TJLC

Junior Member
If the ignition module went out would the truck even run? This problem seems to get worse the warmer the engine gets. I just had a new thermostat put in (A cooler one) and had the system flushed out. I drove it today and it seemed to run ok, so I guess the problem is intermitent. Thanks for the replies. I need to take a day off and find out what's going on with it.
 

Fierospeeder

Junior Member
the ignition module can be intermitent also. I know they came on the 88s so im not sure if you got the type im thinking about. It has three ignition coils on the module.
Try out your car because sometimes you think you solved the problem, but you haven't. I done that before and the problem comes back.

Another thing can be your EGR valve being stuck, its a circular shaped diagram.
 

Top Forums

Similar threads

Similar threads

Top