1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

broke on first push brand new 8600sw

Discussion in 'Blizzard Plows Discussion' started by sleeper1g, Feb 22, 2011.

  1. sleeper1g

    sleeper1g Junior Member
    Messages: 12

    like it states had plow lowered did a single push to clear snow from end of driveway, went to raise plow to back up no go, so i tried straightening it out, no go, tried moving it right since it was left and it went right, but wont come back and wont lift, tried pushing into a hill to put in the lockout pin/bolt, but it wouldnt lift that way either and i wasnt about to drive 20 miles an hour into a hill. this plow was installed 3 weeks ago and has been in the garage ever since till last night when i put it back on for this snowfall 5inches max, i checked it before i left it worked fine, up, down, left, right, float, etc all good, after first push nothing
    fluid is still full, no leaks, all connections are good, control is operable (no flashing power button or float light)

    i tried to disconnect plow from truck got halfway and the hydraulics wont release the second half of the way, so im really stuck now, truck is in the middle of my grandmas driveway so its not a huge deal, but its a big deal that a 5k plow is inoperable after the first push, and it was about 15 foot distance of a push

    i hope this is not a sign of things to come

    any idea where to start, i had installed 3 hours away so its not gonna happen to take it back there even though its under warranty.
  2. jb1390

    jb1390 Senior Member
    Messages: 710

    Put a ratchet strap on it to lift-and drive it back to the dealer if you can't diagnose yourself. I am not familiar enough with the blizzard setup to offer technical advice-but be careful about messing around too much and voiding your warranty.
  3. sleeper1g

    sleeper1g Junior Member
    Messages: 12

    well i was thinking that but i tried to dismount the plow and got halfway and it stopped and it wont allow me to re-engage the mount arm
    so im not so sure driving it anywhere is safe at this point
  4. ddb maine

    ddb maine Senior Member
    Messages: 832

    have you called your dealer? It sounds like its electrical. Blown fuse? When I had my blizzard installed they had to take out the original truckside wiring and replace it because it kept blowing fuses in the shop. They did this before I picked it up of course.
  5. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,779

    Check the joystick connection plug, make sure it's done up all the way, specially if it's mounted on the door.(under your dash)
  6. bhmjwp

    bhmjwp Senior Member
    from kcmo
    Messages: 309

    Check all the electrical connections-start at controller and work your way to under the pump box. Usually something very simple.

    At one time I always had all my plows installed by the dealer, just simpler and easier. The last 3 years I started installing all our plows myself, once you do-90% of the time it can be fixed in a short time. Also buy the spare parts kit recommended, a great insurance policy!
  7. WIPensFan

    WIPensFan PlowSite Veteran
    Messages: 3,594

    Did you check everything under the hood? Connection to battery, maybe something wasn't tighened up. When you use the control do you hear the pump or is there nothing happening?
  8. sleeper1g

    sleeper1g Junior Member
    Messages: 12

    Ok well I feel like a ******.... I thought the pump took a **** but my brain did it was a 5 amp fuse I now have 10 in the glovebox