1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

bought a junker, plow wont work.....help?

Discussion in 'Truck & Equipment Repair' started by bssr, Oct 30, 2009.

  1. bssr

    bssr Junior Member
    Messages: 2

    Ok I purchased a gmc 3500 '96 6.5L Diesel as an emergency backup. Came with a mm1. when i went to pick it up the plow worked, however the fuel pump was gone along with many other things and i couldnt drive the truck back to my lot. So I hooked up the plow to my 07 2500 with a mm2 and drove the plow home. Plow worked fine. Sent the truck in for a new fuel pump, fuel line, alternator, 2 new batteries etc... Also got my polycaster spreader installed at the same time. Got the truck back today installed the salter no problems. Went to install the plow and NO Power to the plow at all. No here is where I get stumped:
    - Plow worked on current truck a week ago no problems.
    - Plow worked on 07 a week ago no problems.
    - Lights do work on 96 now. But no power to the pump.
    - All the power lines are hooked up to the new batteries.

    here is where i think the problem might be, but can't find anything on the subject.

    I realised today that the guy who sold me the truck kept the joystick. So I'm currently using the joystick off my mm2. The power light comes on no problem but no controls at all.

    I ordered a new one off ebay, but its off an 04? is this my problem? is a mm2 joystick not compatible with a mm1 plow? I figured a 6 pin was a 6 pin all the same.

    Anyone got any ideas?


  2. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    Controller shouldn't matter. Does the MM1 work on the 2500?
  3. bssr

    bssr Junior Member
    Messages: 2

    yes works perfectly
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    They probably missed the small black/orange ground lead at one of the batteries that grounds the plow harness. Happens often.
  5. slongfellowii

    slongfellowii Senior Member
    Messages: 157

    Bad solenoid or they never hooked the small ground wire to it.
  6. Joe Lombardo

    Joe Lombardo Member
    Messages: 63

    Had the same problem, replaced the motor relay (solenoid) no more problem...