1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss Vplow Controller won't turn on?

Discussion in 'Boss Plows Discussion' started by ctak99, Feb 23, 2013.

  1. ctak99

    ctak99 Junior Member
    from USA
    Messages: 2

    So I plowed all day yesterday, I stopped at a buddies house, I left the truck running, but turned the vplow controller off.

    When I came outside, I wanted to plow his long driveway as I left, the controller wouldn't turn on. The light switch works, but nothing else. I chose ON/OFF on the controller, nothing happens, no lights light up like the usually do.

    I have the boss vplow handheld controller. I checked under the hood quick, found 1 large 40amp and 3 small 10amp fuses, that are fine.

    Anything else to check?


    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    Check the keyed ignition fuse.
  3. tuney443

    tuney443 PlowSite.com Addict
    Messages: 1,847

    Also check your in the cab harness connection off your controller but I bet your wire at the keyed fuse fell off or isn't making contact.
  4. ctak99

    ctak99 Junior Member
    from USA
    Messages: 2

    Well I took the controller out of the truck, brought it inside, took it apart, everything looked ok, the connectors to the switch. Hooked it back up. Still nothing.

    Kept wiggling the swtich turning it on/off again and I saw the light on the switch flicker on/off, so I messed with it enough and got it to work!.

    So its just a loose or crappy on/off switch in my controller.
  5. ihdriver7088

    ihdriver7088 Senior Member
    Messages: 315

    switch is crap on controller had mine do o\it and a friends controller as well
  6. StratfordPusher

    StratfordPusher Senior Member
    Messages: 960

    Joystick Failures

    In all the years I have had run Boss plows I have never had a controller issue until this year.

    Brand new plow this fall, last big storm my plow started acting funny, right wing would not operate on it's own, worked in vee mode only, left wing worked ok, Mark @ Nes-tech changed it out for a brand new unit off the self. That lasted all of an hour and failed, this time it would not move the left wing..... then it failed completely, glad I had it up and in Vee when it happened.

    Mark changed it out for a used controller and it was up and running again, working ever since.. so it could be a bad batch of comtrollers got out of the factory.

    Guess I will see what happens when I get another new controller... thinking I want to keep the used unit now as a back-up....