1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss v plow

Discussion in 'Truck & Equipment Repair' started by Bigbossman, Feb 11, 2016.

  1. Bigbossman

    Bigbossman Junior Member
    Messages: 3

    My boss v plow with smart hitch won't go up I just got it and manually pushed the light bar up like I did with my old straight blade could it be air locked? I tried bleeding the hoses but it didn't :mad:
  2. k1768

    k1768 Senior Member
    from NJ
    Messages: 556

    All other functions work? Was the controller in float mode? If yes to both, it may be a bad switch on the tower.
  3. HDpullingpower

    HDpullingpower Junior Member
    Messages: 14

    Dumb question, did you make sure plow and controller was in float mode.
  4. Bigbossman

    Bigbossman Junior Member
    Messages: 3

    All functions do work i tried in float position and up I'm still wondering about the air lock

    SHAWZER PlowSite.com Addict
    Messages: 1,288

    Does the pump run when you hit the switch ?
  6. Bigbossman

    Bigbossman Junior Member
    Messages: 3

    You can hear the pump bypassing
  7. Snow tracker

    Snow tracker Senior Member
    Messages: 137

    Hold the down switch in center of controller until it lights up red
  8. BUFF

    BUFF PlowSite Fanatic
    from FR NoCo
    Messages: 9,095

    Have you check the grounds?
    If you have power at the hitch switch and the pump runs check the smart hitch solenoid for power and magnetism. If that all checks oot you can have debris in the valve, pull the valve spray carb cleaner in it and blow with compressed air.

  9. Snow tracker

    Snow tracker Senior Member
    Messages: 137

    So it does activate the pump? I had one that had a faulty ground once that sounded like the same problem you are having??? Might be something to check. Otherwise the valve is not changing flow from switch command.