Snow Plowing Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
so I have a 2002 gmc 2500hd and a I got a 2002 Chevy 2500hd I took the plow and harness off the Chevy and put in on my gmc my problem is the headlights not working even when I unhook the plow the harness plugs are on B side but the high beams are stuck on but not coming on what am I doing wrong
 

· Premium Member
Joined
·
17,092 Posts
Definitely a problem with the A/B. I think 99-02 was A side, 03+ was B

Ultimately, you need to make sure the common wires on the truck headlight connectors are matched properly to the common wires on the plow harness. You may need to use a test light to determine which they are
 

· Registered
Joined
·
3,062 Posts
DID you flip the switch?

Every year I forget to turn the SWITCH and spend 1/2 hour trouble shooting before I remember that BOSS has this STUPID switch.

On my new Boss i fixed it. If the plow is plugged in the plow lights work. Unplug the plow and the truck lights work. NO f ing switch to forget.
 

· Premium Member
Joined
·
17,092 Posts
DID you flip the switch?

Every year I forget to turn the SWITCH and spend 1/2 hour trouble shooting before I remember that BOSS has this STUPID switch.

On my new Boss i fixed it. If the plow is plugged in the plow lights work. Unplug the plow and the truck lights work. NO f ing switch to forget.
The switch would not cause the high beams to stay stuck - that is invariably from the ground being crossed
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top