1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss RT3 SmartHitch Not working & issues

Discussion in 'Boss Plows Discussion' started by SnowMan_76, Oct 16, 2016.

  1. SnowMan_76

    SnowMan_76 Junior Member
    Messages: 7

    Ill try to keep this short & to the point but thorough. Have a few questions.

    SmartHitch switch on light tower Not working correctly.

    Just got plow , used, off same year truck as mine. Has set unused for close to 2 years that I know of.

    Pulled up to plow, laid wire harness out and rough wired everything except lights up.

    Plow at first would not go left & right correctly, one way would the other way wouldn't, don't remember which. Kept moving controller left to right and it started working, assumed just stuck or air or whatever from sitting.

    All plow functions worked correctly, including Switch on light tower for the SmartHitch feature.

    Tried plow at least half dozen times through the day and everything worked.

    Disconnected, ran wiring harness, installed everything on truck, hard wired and done.

    I cleaned connections & pins on the main 13 pin plug. Cleaned main 12volt positive & negative cable connector at front of truck.

    1. Now the SmartHitch switch does Nothing while controller is in Float position.

    2. SmartHitch switch Does work if somebody is holding controller in raise position.


    Question : When controller is in Float position, are there any wires that are hot / energized on the switch itself and/or any of the coils on the valves? I've tested every wire for 12volt and no wire shows anything.
    No coils are energized when in float position. Not sure if this is correct???

    3. A couple times also now when controller is in Raise, the plow will turn Left instead. Click controller joystick to right and it goes right, click left and it goes left. But several times now when raised it goes left instead.

    There is one coil on the valve body that I've not detected any magnetism on or voltage. If you're looking at the valve body, top right is a double coil valve which is left / right I believe.
    Then on center/left of valve body you have 3 coils with the nuts facing you
    Top right is I believe the SmartHitch coil. I've detected nothing there.
    One below it I have, and to the left that one also.

    What's going on with everything????
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,390

    Get the manual to start with.
    Just a hunch, but if one coil doesn't have magnetism when you check ALL operations I'd say that's a problem
  3. SnowMan_76

    SnowMan_76 Junior Member
    Messages: 7

    I've read every manual online I've found and other sources of info and no answers to my issues / questions.
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,390

    So it worked when you just laid the wiring down, but when you "installed it" it's not working right......firt thing is double check ALL the connectors, wiggle jiggle them. Then I would follow the wiring diagrams to see what I'm missing
  5. SnowMan_76

    SnowMan_76 Junior Member
    Messages: 7

    I've done all of that as stated.

    This appears to be a multi-part issue, but maybe not.

    Note: In the wiring used, I never messed with or made any connections into the actual plow wiring, it was intact from plug to plug. Only things I "wired" up temporarily and permanently were :
    Fused pwr to controller
    Brown ground & Brown to Solenoid
    White/Black wires to Solenoid
    Main 12volt & Ground cables

    It was pretty simple & Straightforward
    Nothing has changed as far as wiring, and all connections have been thoroughly cleaned & are in good shape.

    The lights I ran all independent from the factory / Boss connections & relays etc as it did not come with the used harness. Lights run off 2 toggle switches, 1 for low, 1 for high

    So basically the wiring is simple, and works / functions as stated in my original post.

    It's either something in controller
    The tower switch
    Also a bad coil or valve
    Or a combination of them all, judging from what its not doing, and doing what it's not supposed to do.
  6. potsie

    potsie Junior Member
    Messages: 1

    Check both ends of the electrical pigtails for corrosion.
  7. SnowMan_76

    SnowMan_76 Junior Member
    Messages: 7

    I've already done all that as stated previously. Has nothing to do with any connections.
  8. cwren2472

    cwren2472 Member
    Messages: 89

    Look at the control plug on the plow side and actually count the number of pins in it. Frequently, there is one pin that normally sits off to the side on its own that bends over time and breaks off. It is used to energize the solenoid when you hit the smart hitch switch. If the plug has 3 rows of 4 pins, you are missing one. If it has 2 rows of 4 and 1 row of 5, then there is a different issue.
  9. SnowMan_76

    SnowMan_76 Junior Member
    Messages: 7

    Problem solved and questions answered after talking with Boss Tech Support.

    1. While in float position the Orange wire ( down coil - top left coil ) is energized.

    2. Orange wire sends power to SmartHitch tower switch. Power goes through the switch (when acrivated) to the Black wire ( top right coil " SmartHitch coil " )

    I was getting no power to Orange wire.

    Tested Orange wire from Controller at the 9 pin connector - Positive for power.
    Conclusion - Controller is good & issue is now between the 9 pin connection and Coil , which is the 13 pin connector OR wiring itself.

    Tested 13 pin connector - No voltage detected.

    Started peeling off shrink tubing on truck side of 13 pin connector , uncovered butt splices from previous repair ( connector pigtail replacement)

    Orange wire was corroded green and broken at the butt connector.

    Temporarily stuck it back together and everything works.

    Now...... Cutting out all butt connectors and soldering then shrink tube the splices.