1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss RT3 Problems

Discussion in 'Truck & Equipment Repair' started by SnowMan_76, Oct 16, 2016.

  1. SnowMan_76

    SnowMan_76 Junior Member
    Messages: 7

    Ill try to keep this short & to the point but thorough. Have a few questions.

    SmartHitch switch on light tower Not working correctly.

    Just got plow , used, off same year truck as mine. Has set unused for close to 2 years that I know of.

    Pulled up to plow, laid wire harness out and rough wired everything except lights up.

    Plow at first would not go left & right correctly, one way would the other way wouldn't, don't remember which. Kept moving controller left to right and it started working, assumed just stuck or air or whatever from sitting.

    All plow functions worked correctly, including Switch on light tower for the SmartHitch feature.

    Tried plow at least half dozen times through the day and everything worked.

    Disconnected, ran wiring harness, installed everything on truck, hard wired and done.

    I cleaned connections & pins on the main 13 pin plug. Cleaned main 12volt positive & negative cable connector at front of truck.

    1. Now the SmartHitch switch does Nothing while controller is in Float position.

    2. SmartHitch switch Does work if somebody is holding controller in raise position.


    Question : When controller is in Float position, are there any wires that are hot / energized on the switch itself and/or any of the coils on the valves? I've tested every wire for 12volt and no wire shows anything.
    No coils are energized when in float position. Not sure if this is correct???

    3. A couple times also now when controller is in Raise, the plow will turn Left instead. Click controller joystick to right and it goes right, click left and it goes left. But several times now when raised it goes left instead.

    There is one coil on the valve body that I've not detected any magnetism on or voltage. If you're looking at the valve body, top right is a double coil valve which is left / right I believe.
    Then on center/left of valve body you have 3 coils with the nuts facing you
    Top right is I believe the SmartHitch coil. I've detected nothing there.
    One below it I have, and to the left that one also.

    What's going on with everything????