1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss RT2, power light doesnt come on. but plow works???

Discussion in 'Truck & Equipment Repair' started by GSS LLC, Jan 31, 2014.

  1. GSS LLC

    GSS LLC Senior Member
    Messages: 640

    Alright, my flunky employee that likes to be a mouth breathing idiot gets the derelict truck. 83 chevy with a beat to death 3 times rt2 (literally it has been torched, cut, and welded back together 3 times after major catastrophes). this plow owes me NOTHING.

    so, it was having erratic operation issues. move, not move, move, etc. so i cleaned all the grounds. and the power connections. added a engine to frame ground. motor ground cleaned and tightened. solenoid connections replaced. then the batteries tested poor so i replaced both of them.

    still, the power light on the joystick box doesnt light up.:confused:

    plow works like a champ, at least for the 30 seconds i was moving it in all directions. but the light is inop.

    any grand ideas? :mechanic:
  2. 98K3500

    98K3500 Member
    from WI
    Messages: 46

    Hate to state the obvious, but maybe the bulb that lights the switch is out???
  3. Diesel Dan

    Diesel Dan Senior Member
    Messages: 219

  4. dirtyscag

    dirtyscag Senior Member
    Messages: 121

    So the plow stops after 30 seconds? and controller stops working? We had a problem like that with an rt3 it ended up being a bad connection in the fuse panel the wire that feeds power to the controller was lose.
  5. derekbroerse

    derekbroerse 2000 Club Member
    Messages: 2,377

    I had a controller like this for years, worked great, no power light. I never cared to take it apart and check, just assumed the bulb was gone. Eventually the contacts in the joystick wore out anyways and replaced it. Problem solved.