1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss Power Vee problems

Discussion in 'Boss Plows Discussion' started by ABRUHIN, Dec 30, 2010.


    ABRUHIN Junior Member
    from CT
    Messages: 1

    I have a Boss Power Vee with a problem. When the Smarthitch switch is in the install position the plow frame will load as designed. After mounting the plow and moving the switch into the normal plow position the blade will pick up but only angle, vee or scoop with the blade in the air. If I lower the plow to the float position it will not angle, vee or scoop. I hear the pump motor running. If I put the Smarthitch switch into the install position the blade will angle, vee and scoop on the ground but will not pick up, it lowers and try to lift the front of my truck. This has been like this since I put it on (bought used). I accidentally found out that it would angle, vee and scoop in the Smarthitch position this season. Any direction will be great. Thank You. Al Bruhin
  2. ProSeasons

    ProSeasons Senior Member
    Messages: 624

    Don't worry, B & B will be along here shortly. When it comes to Boss plow problems, he's the go to guy.

    But I have a question, I see you bought it used. Do you think the previous owner tried to install a down pressure modification of some sort and screwed it up?
  3. Jewell1386

    Jewell1386 Senior Member
    Messages: 139

    switch might be shot and if that DP was not installed right it will cause that switch to not work as designed
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    By your wording it sounds like a Smart Hitch 1 model.

    Pull the pump cover and disconnect the wires from the rear of the toggle and check all plow functions. If it works fine now then replace the toggle. If it still doesn't (and nothing wiring related has been previously modified) disconnect the controller and run a manual function test without the controller using this post here.