1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss Plow Problems

Discussion in 'Truck & Equipment Repair' started by ghavens, Dec 21, 2008.

  1. ghavens

    ghavens Junior Member
    Messages: 11

    I have been pulling my hair out, almost bald now.

    I have a Boss RT3 Straight Blade system and it is mounted to a 1996 Chevy Suburban.
    I had taken the plow off a 99 Dodge Ram and installed to the Chevy about a month ago.

    All was working ok, until Friday when it started acting up during our heavy snow in MI. I got stuck in deep snow, pulled off the driveway. After getting unstuck it was plowing ok, then started acting up where the plow worked, then it didn't, then it worked again.

    After driving home I put the blade down in my driveway, and that was all she wrote, blade will not go up or down. The lights on the control are very dim. I did get the control to get the plow to bump a few times, but now it is up a couple of inches, and I can not even detach from the Surburban, nothing. I have checked the connections and cleaned up all connectors and applied Dielectric Grease to all connections. Ground it directly to the battery. Also, the headlights stopped working, they were only working on low beams previously after hooking the system up, but on Friday the running lights come on, but if switch all the way to headlight, I get a clicking sound.

    Anything to check specifically would be a great help. I do not have a spare hand control to try, so I do not know if this could be the problem.
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    sounds like ground issue. check connections at the motor. loose cables anywhere beg for trouble.
  3. ghavens

    ghavens Junior Member
    Messages: 11

    Forgot to mention, I also removed, cleaned and applied dielectric grease to the plow motor as well. I also thought it seemed like a ground issue.

    Still no luck.
  4. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    check your solenoid. jump across the 2 large studs and see if the motor runs.
  5. ghavens

    ghavens Junior Member
    Messages: 11

    I will check first thing in the morning.

  6. yard5864

    yard5864 Senior Member
    Messages: 149

    sounds like an issue I had. The 13 pin connector on the front of the truck was loaded with snow and came just slightly unplugged.
  7. ghavens

    ghavens Junior Member
    Messages: 11

    Still no luck

    I have checked ground, cleaned connectors at the relays also. I have power at the plug for controller.

    I do get the motor to engage if I jump the two big terminals on the solenoid also.

    Lights on controller are very dim and do not engage pump when pressed. If I press on the center down and hold it will go red like in float mode.

    Still baffled and with no working plow.
  8. MileHigh

    MileHigh PlowSite.com Addict
    Messages: 1,827

    Post this in the boss forum.

    I'm sure you will get the answers you need there.

    But I think if you put the plow in float, you should be able to move the ram or plow down by hand, and then you should be able to disconnect at least.
  9. ghavens

    ghavens Junior Member
    Messages: 11

    I have posted in Boss section. I can't disconnect, I have the Smarthitch II so I need to power it down to release it, and it is up about 1-2 inches. I can put the controller in float, and the button goes red, very faintly, but I don't think it is communicating because the plow will not go down either.
  10. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    move the connection at the 13 pin connector back and forth when its in float. have someone run the control and do it again.