1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss plow does not work

Discussion in 'Truck & Equipment Repair' started by bsuds, Oct 8, 2008.

  1. bsuds

    bsuds Senior Member
    Messages: 192

    Please help. I bought an 07 7'6" super duty plow from a private party. I hooked the wiring harness up myself. I got the plow lights to work, and the plow worked for a day. I took the plow off and tried to hook it back up. I pulled up on the smart hitch switch and nothing happened. I then went inside the truck and pushed the controller to just see if the plow would move and nothing. The only thing that happened is I heard the solenoid make some clicking sound. I have the main ground wire grounded to the battery and the large red connected to the terminal coming from the alternater. I have checked the fuses going to the solenoid and it looks OK, and also the fuse going to the keyed terminal. The plow looks brand new so I don't know what could be wrong.. Please help.. Thank you.
  2. LawnProLandscapes

    LawnProLandscapes PlowSite.com Addict
    Messages: 1,129

    make sure you have the controller in the "float" position to hook the plow up .. check the harness' for bent prongs in the plug. use a test light and probe truck side harness to make sure everything that needs power is getting it when need.
  3. F250 Boss v

    F250 Boss v Senior Member
    Messages: 281

    You should see a red light on your hand controller when its in float.
  4. bsuds

    bsuds Senior Member
    Messages: 192

    I checked for power in all areas of the plow, and found some very wierd things. I have the negative and positive power cord coming from the plow connected to the truck side. The negative is grounded at the battery and the positive is running up to the solenoid. The positive cord that goes from plow to truck solenoid is reading a negative current. I have another positive cord connected to the solenoid coming from the the from the alternator positive power box that is being fed from the positive part of the battery. This wire is reading positive as it should be. So the wires connecting to the plow are both coming up negative for some reason, and when I check the current inside the plow area everything is coming up negative current. My solenoid is not grounded to anything. I don't know why the power part of the power/ ground cord would give me a negative current.
  5. LawnProLandscapes

    LawnProLandscapes PlowSite.com Addict
    Messages: 1,129

    disconnect the positive power cord from the positive box on the alternator and jump it right to the positive on the battery of the truck and give her a rip...

    did you double check that you have controller in float position??
  6. wild bill

    wild bill PlowSite.com Addict
    Messages: 1,239

    ,you have to have power to the control ,check your fuse at the battery and inside like previously noted the control has to be in float,to send power through the solenoid .:waving:
  7. bsuds

    bsuds Senior Member
    Messages: 192

    Thanks guys i will try your ideas tomorrow and let you know how it turns out. I appreciate all the help you guys have to offer.
  8. bsuds

    bsuds Senior Member
    Messages: 192

    Hey guys I think things are working for the most part. The only thing that is acting up now it the smart hitch2 switch. I put the controller in float and hook up the plow. So it does go up. But when I unhook the plow I push up on the switch. The plow disconnects and then I push down on the switch. I can hear the motor running but there is no down force applied. The plow goes down and disconnects only because of gravity. What could this be? Thanks for you help.
  9. Indy

    Indy Senior Member
    Messages: 704

    Check you fluid level also
  10. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    How do you know there's no "down force"? They have very little hydro assistance during the disconnect...and don't need much as you discovered since it'll lower virtually by gravity alone....sounds like it's working normal to me.