Snow Plowing Forum banner
1 - 18 of 18 Posts

· Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello I have a blizzard 8000LT plow and when I was pushing the ends of the driveway the plow went all the up with the snow and now the power light on the controller is blinking and i don't have any control or the plow at all what could it be thank you in advice
 

· Registered
Joined
·
14,949 Posts
Did you ck the grill connections?
What about the fuses?
 
  • Like
Reactions: Western1

· Registered
Joined
·
7,366 Posts
Not familiar with this plow, are there switches on the head gear for mounting the plow? Did one of them get tripped?
 

· Registered
Joined
·
7,366 Posts
The slow blink indicates a communication problem. When I found this out the hard way it was after mounting the plow and not flipping the tower switch to plow control.
Bad switch there or broken wire, dirty terminal in the plug?
 

· Registered
Joined
·
362 Posts
Check the switch again on the light tower. The switches can get pretty weak and break where it makes connection to the wire. It could be stuck in the "mounting" position. Feel if it feels slightly more loose than the other switch. Had this happen twice, both blizzard plows.
 

· Registered
Joined
·
860 Posts
A typical problem in this "stacking" situation with PH2 Blizzards is a pinched power cord on the plow. Often times the power cable will get trapped between the a-frame and the lower part of the light tower. When "squeezed" like this, everything seems to be fine but the controller can't communicate correctly with the plow module and sometimes will result in a "no-com" slow flash. Many times after the plow sits and settles ever so slightly, the function will return on its own. Check routing of the power cable and for signs of this squeezing.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top