1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Blizzard 810 Problems

Discussion in 'Blizzard Plows Discussion' started by prayforsnow, Dec 2, 2005.

  1. prayforsnow

    prayforsnow Member
    Messages: 35

    Howdy All,

    I hope someone here can tell me how to fix this 3 year old plow, before I replace it with a perfectly operating 20 year old plow and thirty year old lift unit. :help:

    First off the power hitch only works occasionally. Sometimes it will reach out and grab the truck when you hit the switch,other times the pump whines like fluid isn't flowing and it will either move a fraction of an inch, or not at all. If you keep flicking the switch (sometimes twice,sometimes 20 times) it will work. Kinda' spooky when it's ON the truck...knowing you can't get it off unless it lets go (gaaaaah!). :eek:

    It also does the same thing when lifting...it will lift it a foot (once), 6 inches (a couple times), just preload the front suspension (several times), or not lift it at all (what I ended-up with).
    I take it the same hydralics work the lift and power hitch?

    And yes, I had the hook thingy (purely technical term) up out of the way and pinned...that is where it's supposed to be, correct?

    The power angle works strongly, and the wing operation seems to work alright...

    All four hoses (x2) for both wings were disconnected this summer for a while so I could fix one of the wings, if that makes a difference.

    I snapped the 3/4 inch pin the wing pivots on, backing into piled snow with the wing extended...and that crushed the snow shield when it retracted.

    How do you loosen the solinoids to bleed the switch block? How do you test the solinoids?

    My local dealer is sort of a tool, and the Blizzard tech guys (and gal)are hard to get a hold of.

    Any help anyone can give would be greatly appreciated...thanks in advance.

  2. Detroitdan

    Detroitdan PlowSite.com Addict
    Messages: 1,937

    I had a problem like that, only it wasn't intermittent, it was all the time, I couldn't even get the plow on. I had to take it in to the dealer, thought it was a solenoid but it ended up being a broken wire behind that switch. You may want to look behind there, see if everything is tight.
  3. prayforsnow

    prayforsnow Member
    Messages: 35

    Hi DD,

    Thanks for the idea, I'll check it this morning. I've got 3 inches of snow coming this afternoon, and if I don't get this thing working by this afternoon I'm putting the old Monarch unit and Meyer plow on.

    As for that switch I had to replace it already...three year old plow and the switch came apart in my hand. :mad:
    Went to Blizzard and they wanted $35.00 for a stinkin' toggle switch!:eek:
    Instead I went to Radioshack and got the same switch...same pinout and everything, for less than 5 dollars with tax. :p
    I guess it's kinda' like the re-badged fluid for $8 a quart...

    I guess I'm gonna try bleeding the system,check all the wires,tighten the bolt on the power hitch...everything I've read on here.

    Otherwise, I'll have a good deal on a Blizzard 810 for somebody tomorrow!:rolleyes:

  4. SnoFarmer

    SnoFarmer PlowSite Fanatic
    from N,E. MN
    Messages: 9,883

    You said you had disconnected some hoses ? cheek your hyd fluid level & bleed the air out of your system, then cheek all of your electric connections.
  5. prayforsnow

    prayforsnow Member
    Messages: 35

    Thanks Farmer,

    I'm going to do just that now...

    First I'm gonna' clean the plug and contacts...and try to hook-up the plow.

    How exactly are you supposed to bleed the air out of the system?
    I wonder if air would get trapped at the top of that aluminum block(where the solenoids are)...and if so, how would you get it out?

    Blizzard's troubleshooting guide is kind of vauge, and doesn't go into much detail...

  6. SnoFarmer

    SnoFarmer PlowSite Fanatic
    from N,E. MN
    Messages: 9,883

    Some will tell you to just keep on moving the plow back and forth and up and down and keep an eye on the fluid level in the reservoir. While others will loosen a fitting at the ram little and run the system a little until only fluid comes out then tighten it up and do this to an other one.
  7. prayforsnow

    prayforsnow Member
    Messages: 35

    Well, I got it on the truck again...but it wasn't easy.:eek:

    Correct me if I'm wrong (pleasecorrectme!), but the hook has to be in the up position and pinned for the plow to lift, right? :confused:

    I cleaned the main plugs,checked the plug on the solenoid pack for dirt or corrosion (none),and tightened the bolt/nut on the power hitch finger.

    I'm guessin' it's the valves for raise/lower/float...

    Any other idea's?

  8. Jon Geer

    Jon Geer Member
    Messages: 834

    Well, let's start by making sure the attaching arm bolts are not super, super tight. Then check to see if the pickup tube filter in the tank is pointing down (sometimes it works it's way turned up). Bleed all the air out of the system by loosening the hydroturn cylinder fitting and manually moving the plow back and forth until all the air is out. Replace fluid, test functions. Make sure you are in the PowerHitch mode as well.

    Let me know.


  9. prayforsnow

    prayforsnow Member
    Messages: 35

    Hi Jon,

    First off...Thank you very much for your concern and advise...it is greatly appreciated.

    After removing the coils and valves for lift function...didn't really see anything in them, cleaned them over a clean white rag...not much to see there either. Nothing that looked like it would have made them stick.
    Anyway, after reassembling, the plow lifted like a champ!:drinkup:

    But...now...it wouldn't float or lower! :gunsfiring: :yow!:

    Removed and cleaned those valves...still wouldn't lower.:confused:

    Long story slightly shorter...

    There is a broken wire or contact in the wire loom on the plow....
    After moving the wires around (numerous times) I now have the plow where it will raise and lower (in the garage) but I wouldn't dare take it out plowing.

    While digging around try to see if the wire was easily spotted I thought it might be under the diode pack (just exacly what does that do? And does it matter which way it is plugged in?)
    I discovered that the diode pack wasn't plugged in at all, just resting on the contacts inside it's clear plastic cover. But plugging it in didn't make a difference.

    I can disturb the wires and the pump won't even run...nothing works at all. All you hear is the clicking of the main solenoid under the hood. Power is being delivered to the motor, but it won't run.
    I can push the wires togther (by the solenoid block) and get everything to run, just usually not all at once.

    How much is a #362039 plow harness? Could one bad ground on a solenoid do something like this?
    Does it sound like anything you've encountered before? Would you look at any certain wires first before checking them all for continuity?

    It seems like there is a feedback loop coming from the plow to the in-cab controller...when this wire isn't making contact, the "float light" doesn't illuminate...or...sometimes it will, but goes out when the joystick is moved (without anything happening of course).
    Almost sounds like a bad ground wire...and yes, I did pull the bolt holding the ground wires, clean the contact points (wires, bolt, and plow surface)...but at that time I didn't inspect all the ground wires before putting it back together.

    Anyway,I would greatly appreciate you thoughts and input...

    Thanks again,

  10. fastjohnny

    fastjohnny Senior Member
    Messages: 654


    I can sense your frustration in this thing, however, I would try eliminate possibilities one at a time.

    Do the right and left functions work? How about the wings? If they work, your solenoid should be fine. If the main solenoid works for one it should work for all.
    You may be on to something with the diode pack.
    With the intermittant nature of your problems, I would point toward your plug, even if it looks good, is there a connection that is not getting good contact? The plug is a known source of failure if not maintained properly with dielectric grease to keep the dust and corrosion out, both on plow and vehicle sides.

    Keep us posted!
    Last edited: Dec 5, 2005
  11. prayforsnow

    prayforsnow Member
    Messages: 35

    I think the main solenoid is the only thing that works correctly...:D

    What I figured out is if I move the harness around on the plow I gain or lose functions.:eek:

    I have all functions working right now, but I can move the wires (multicolored loom near the plug going to the control solenoids) and lose some or all of the plow functions.:dizzy:

    It seems to me it may be a ground issue. If it was any one input wire I would only lose one function...but a bad ground wire (or several?) could cause a loss of several or all.

    How's that sound?:rolleyes:

    Kind of explains the loss of "float light" on the control unit too...

  12. prayforsnow

    prayforsnow Member
    Messages: 35

    Okie Dokie...

    Well, I took my own advice, and even though the ground looms didn't look obviously bad, I re-did them all.

    I clipped all of the wires going to ground (lots of red wires), stipped them back, and applied new connectors. Even though I stripped the wires back 3/8's of an inch or more after clipping them, the wire was still discolored from the start of corrosion (not shiny but dark colored).

    After I put the new connectors on the wires, I sealed them with RTV...worked it in-between the wires above the connectors, and left a coating around the whole bunch.

    Well, that seemed to do it. :drinkup:

    I have had one moment since replacing the ground connectors when the in-cab control didn't respond...:eek:
    But after unpluging/re-pluging the connector inside the cab it worked just fine again.

    Everything seems to be working correctly now...if maybe a bit on the slow side for me...next I will try turning-up the pressure a bit and see if that doesn't make things move a bit faster.

    Is there a way to make this plow lift higher?
    It seems like 6-7 inches above the ground is MAX. When the plow is angled the corners drag on anything but totally level ground...and that ain't right...:nono:

  13. prayforsnow

    prayforsnow Member
    Messages: 35

    Anybody know why the plow would just go dead?

    I mean completely dead. Not even the solenoid on the fender is clicking. The only fuses I found were fine. I found a 40 amp glass fuse, and a 25 amp newstyle push-in fuse...both look fine.

    Not a good feeling when the plow won't lift (or do anything else). :eek:

    It says in the owner's manual you can lift the plow on a snow bank and insert a pin to keep it up...only problem with that is the attaching/latching arm moves downward away from the crossmember when the plow lifts. Only way I could get it to stay up was by inserting a chunk of wood between (under) the arm and crossmember. WHAT A PIA! :gunsfiring:

    Anybody have any idea's? Anything I should look at first?

    I love the way this thing plows...but I never had a SINGLE failure with my old Monarch unit in 12 years...not one.

    I can't have a plow that's not reliable... :realmad:

  14. prayforsnow

    prayforsnow Member
    Messages: 35


    I had a blown fuse...well actually a couple. I had popped a fuse in my trucks fuseblock where they had put in a tap for power to the inside control unit.

    It was a 10 amp...didn't have any 10's so I put in a 15...
    After I replaced that, power came back to the system until I tried to angle right...boom...fuse gone again. I had nothing but 20's to replace it with, soooo...I put in a 20...and no power again...:confused:

    Followed that wire under the dash and found a popped antique (glass in-line) fuse that was 20 amps. Replaced it with the only antique fuse I could find that fit the holder. I believe it was a tad larger than 20 amps...probably thirty. :nono:

    Well...after doing that, everything but the right angle worked (WTF?):dizzy:

    Turns out, after lots of testing, jumpering, and a lot of swearing...I have a direct short in the magnet that controls the barrel valve to angle right.

    Just HOW OFTEN DOES THIS HAPPEN??? The magnetic switch is sealed from the factory...WTF went wrong with it??

    The dead short popped the first fuse when I was plowing...which left me dead in the water...killed everything.
    When I upped the amperage of the first fuse I popped the second...and my guess is the combo of the two bigger fuses and the directly shorted magnetic switch toasted the microswitch in the control unit, because it is now dead.

    Does anybody know if I'll be toasting things left and right if I replace the fuses with breakers instead? At least then the whole thing wouldn't go dead because of one problem part.
    It would have been nice to be able to swap S2 with S4 in the field...I would have been happy to have done without right wing extension to get my right angle back...

    Maybe it would be a good idea to fuse each control wire...then one shorted switch wouldn't leave me dead in the water...:rolleyes:


    BTW, Jon Greer...I tried to send you a PM but I wasn't allowed to...???
  15. prayforsnow

    prayforsnow Member
    Messages: 35

    Acccording to my local dealer,

    Blizzard doesn't sell the 'sub' micro-switch separately, but, Radioshack does...or at least a close aproximation.

    I bought the auto latch switch from Radio Shack too...the price difference was about $30.00 between them.

    I don't know about anybody else, but the 'joystick' in my controller feels terrible. Very sloppy, with no feel to it at all...real 'limp noodle-ish' . It's also very inaccurate...when dropping the plow sometimes it will swing right or left with no perceptable side movement of the stick.
    In addition, it has a tendency to stick...and it's a real PIA because I can't hear the lift-motor running over the sound of the engine.

    From looking at the inside of the controller, it seems to me like part of the problem might be the paddles on the switches are too close to the joystick.

    In the switch I just picked-up from RS, the paddle sits closer to the actual switch-body. I'm thinkin' if all of the switches were replaced there would be more room between the paddles and the joystick in the controller...this might make enough of a difference in the way it works.
    Sooo, I may just replace all the switches with RS ones... just to see if it does make a difference.

    The magnetic solenoid I needed cost me less than $20.00...so I guess I have everything to fix the plow...I wonder for how long this time...

  16. prayforsnow

    prayforsnow Member
    Messages: 35


    I put in the new parts (microswitch/magnetic solenoid)...along with a circuit breaker on the fuse block.

    I changed the 30 amp inline fuse with a 14 amp just to keep from toasting the new microswitch when I tried the new parts...just in case.

    Powered-up, lifted the plow, no problem...angled left, no problem...tried to angle right and...bzzzt...it popped the fuse again. :realmad:

    I can switch S2 with S4 solenoid, and using the right wing extension switch, I can angle the plow right...so there's nothing wrong with the barrel valve for right angle...

    I can disconnect the plug on the plow that connects to all the solenoids and not blow the fuse...
    I can apply power to the wire that feeds the pump from the in-cab controller and it will run, no problem.

    There seems to be no obvious breaks or frayed areas in the wire going to the solenoid pack...
    And there's only one way you can install the new solenoid...

    Does anybody out there have any idea's? :help:

    Jon? Care to chime in here? :confused:

    I really like this thing and the way it plows, but if it's going to keep jacking with me, it's going to be for sale soon. :nod:

  17. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    other controllers

    Why don't you build a whole new controller if you don't like the one you've got?
  18. prayforsnow

    prayforsnow Member
    Messages: 35

    Howdy FJ...

    That sounds easy...in theory...too bad it would be WAY more work than I want to do in practice...but...I can't say that I haven't thought of it.
    Funny thing is, I never wanted to change the controller on my Western, Meyer, or Monarch units...I guess cause they worked.

    1st off I'm not an electronics wiz...otherwise I'm thinkin' I would have already figured out what's wrong with this POD.
    I did see a picture of a controller that someone on the list made though...looked nice, and compact too.
    I understand they make a replacement 'touch pad' for the plow. My dealer was sold out of the replacement 'touch pads' when I went there yesterday, so I'm thinkin' I'm not the only guy who's not happy with this controller.

    Secondly the controller isn't my problem...it's forward of there. I just toasted the switch by being a DA and using to big of fuses.

    I can't say that I haven't seriously thought of just replacing the angle and lift microswitches with momentary contact push-switches.
    Only problem is, that's more of an ergonomics type thing, and I'd just like to get the stupid plow to right angle without blowing a fuse first...before I start making the controller more friendly for me.

    Thanks for the input though...

  19. Mark Witcher

    Mark Witcher Senior Member
    Messages: 605

    I have a sugestion. I had a similar problem a few years ago with my Boss plow. It kept blowing the main fuse.What I finally found was I had put too much Dielectric grease on the harness plug from the plow to truck . It was allowing the power to cross over between circuits. So just make sure you dont have excessive amount of grease on the plugs.
  20. prayforsnow

    prayforsnow Member
    Messages: 35

    Hi Mark,

    Thanks for the suggestion.

    I read your idea before on a different thread...I don't remember which one, and I tried it when I couldn't get the plow to work at all...

    I will try cleaning all the plugs thoroughly again then lightly and carefully apply dielectric to them all...what the hey...it can't hurt.

    Thanks again,