1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Blizzard 760LT wont lift with joystick?

Discussion in 'Blizzard Plows Discussion' started by atrinh15, Sep 3, 2010.

  1. atrinh15

    atrinh15 Junior Member
    Messages: 28

    Its early in the season but I put some new tires on my rig and wanted to set the jack on the plow. I noticed the plow on the hitch side would go up and than pause go up and pause again. Than it would do the same thing going down.

    Now the plow all the way up I use the joystick and the plow would drop no problem but wont go up but I hear the motor running. Left and right no problem. Not sure what the problem is. Any ideas would be appreciated.

    Thanks in advance

  2. purpleranger519

    purpleranger519 Senior Member
    from Kansas
    Messages: 536

    If you can hear the motor running then I'd say one of the pick-up tubes fell off in the tank. That's where I would start looking first.
  3. atrinh15

    atrinh15 Junior Member
    Messages: 28

    So inside the tank there are tubes? So I would have to drain it down? Whats the easiest way to drain this tank? Sorry just never worked with this type of plow and not sure.
  4. atrinh15

    atrinh15 Junior Member
    Messages: 28

    Ok so I went onto Blizzardplows.com and found there technical section. Found under troubleshooting some of the possible problems. I think I might have not connected the plugs all way....

    I just tried it and it all worked with both plugs in tight and all the way. Ill see if I run into any other problems. Thanks purpleranger519 for the help