1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Blizzard 7600 will not go up!!!

Discussion in 'Truck & Equipment Repair' started by Sullys, Dec 3, 2013.

  1. Sullys

    Sullys Junior Member
    Messages: 2

    I have a Blizzard 7600 straight blade that was working 2 weeks ago when taken out of storage. I went to hook it up for the upcoming snow and now it wont go up. The power attachment arm goes up and latches but as soon as the plow is about to lift it stops and the pump whines. I tried cleaning connections, hooked a ground directly from battery to check for bad ground, tried tapping anything and everything on the pump. This is the first blizzard I have owned and don't know where to start. Help! Thanks
  2. Sullys

    Sullys Junior Member
    Messages: 2

    Forgot to say it goes side to side fine and is full of fluid as well
  3. babs2972

    babs2972 Junior Member
    Messages: 23

    I had this happen to my 810 years ago. It was the selenoid that controls how fast the plow drops. If I find out what one I will reply with the number. It is the only one that has an adjustment on it. Good luck
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,391

    When was the last time you changed your fluid?
  5. bliz&hinikerDLR

    bliz&hinikerDLR Senior Member
    Messages: 553

    I know this may sound dumb but be sure your kickstand is up. The kickstand rod is made to interfere with the lift arm and wont allow the plow to raise unless it is correctly stowed.
  6. cl733

    cl733 Senior Member
    from Canada
    Messages: 263

    try a direct approach to the solenoids, when you want to get know if its a solenoid or something else, I unplug the harness right at where it hooks up at the the last connection before the solenoids, make a short wire up with some small alligator clips and clip one end on the motor power connection and the other to a wire end in the plug going to the solenoids, and get somebody to make a lift movement , or any movement from your control pad, it will start the motor and activate the solenoid you have clipped to, work your way through all the wires, you should be able to see it lift if everything is good ,if it doesn't you just found your problem ,I do this on an 810 but likely all blizzards are probably the same, some times the wires have a way of working themselves back out of that plug before the solenoids , so watch for that too
  7. babs2972

    babs2972 Junior Member
    Messages: 23

    I found the Solenoid # it is FC which is almost directly in the middle of the valve port on the side facing the truck.

    Please let us all know if you fixed your problem and how, so we all know the fix if it happens to us.