1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Bad Handheld Control???

Discussion in 'Boss Plows Discussion' started by johntwist, Jan 2, 2006.

  1. johntwist

    johntwist Senior Member
    Messages: 415

    At the beginning of the season, I had trouble hooking up. With all connections checked and right, the hydraulics would not engage. I got lights no problem, but trying to raise the plow with the toggle switch on the headgear just made the solenoid click and nothing else. I replaced the solenoid and that seemed to do the trick.

    Now....I have a new problem. Hooked up today, raised the plow, checked everything, she moved around fine, raised & lowered fine, all lights working, everything seemed great. Parked the truck, dropped the blade and went about other things. After a few hours, I had to move the truck and now the blade will not raise. She'll move side to side, but not up. Here is what happens when I turn the plow controller on:

    The pump immediately kicks on, like it's stuck in trying to lower, but it's already on the ground. Hitting the up/down controls do nothing and it will not go into "float" mode. Hitting the left/right buttons will move the plow in either direction. If I leave the controller on more than say 15 or 20 seconds, the 12 volt cables begin to get really HOT and my "Check Gauges" idiot light comes on on the dash.

    Anyone have any ideas what the hell is wrong here? All I can think of is that my control pad is bad and the "down" button is stuck, although it's barely 2 years old and has been taken good care of. No...I didn't spill my coffee all over it or anything. HELP!!! :dizzy:
  2. Mick

    Mick PlowSite.com Veteran
    from Maine
    Messages: 5,546

    Hi, John. Just got back on PS. First, I don't have any experience with Boss plows, but...

    First, I'd think about ice in the hydraulic system and fluid level. Assuming you're all hooked up right (it's only two years old, so shouldn't be corroded), I'd take the controller apart and clean it with compressed air. Check your owner's manual, they might have a recommendation for another method of cleaning it. Is it possible your vehicle battery or alternator is kaput? It takes a lot more juice to lift it than to angle when it's lowered.
  3. johntwist

    johntwist Senior Member
    Messages: 415

    Thanks for getting back so quick Mick.

    I did take the controller apart, but it's clean as brand new inside and it's just a little computer board, no mechanical parts, nothing wrong I could see.

    Fluid level is where she should be. I don't think she's got water in there, but I won't know for sure unless I end up having to drain/re-fill. One guy I talked to said it must be the solenoid stuck. I hate to think that's it, the damned thing is brand new, put it in 3 weeks ago! I even tried whacking the solenoid a few times with my pliers to see if I could "un-stick" it....no luck. Don't know what else to do until the shop opens up in the morning, but thanks anyway, it never hurts to ask, right?
  4. The Boss

    The Boss 2000 Club Member
    Messages: 2,099

    John, I had the same problem with my old straight-blade. I too thought it was the solenoid. I took apart every electrical connection on the plow and cleaned them along with putting corrosion preventive grease on them. I also did this on the wires coming from the solenoid under the hood. After that. never a problem. Hopefully this helps bud.
  5. johntwist

    johntwist Senior Member
    Messages: 415

    Problem Solved!

    Thanks for the suggestions and quick response Mick, Jason.

    Wouldn't you know it turned out to be nothing more than a bad hand-held controller just like I figured? Guy down the shop said they've had alot of problems with defective controllers like mine, not the joysticks though. Anyway, the good news is they're getting me a new one under the warranty and set me up with a loaner for now so my rig is back up. I only missed about 3 hours of sub work because our 'big storm' turned to rain and we ended up with hardly any accumulation. Not too bad you know.
  6. Deere John

    Deere John Senior Member
    Messages: 410

    Any detail on what was wrong with the controller - I have two units that are no longer on warrantee, and I'm just wondering if they are a repair or replace-only item.
  7. johntwist

    johntwist Senior Member
    Messages: 415

    Sorry, no specifics, he just said the thing was bad. I bet it's hard to say unless you're an electronics whiz. When I took it apart to check it out, I found the rubber buttons pretty much directly connect to a little mother board. Even though mine was basically stuck in "lower", there was nothing you could see that would tell you what was causing it to malfunction.
    Next time I'm down the plow shop, I'll ask the guy if he knows any more details about it and if so, I'll post 'em.
  8. Deere John

    Deere John Senior Member
    Messages: 410

    Thanks - I thought we had one acting up, but it turns out it was the solinoid - a brand new one I put on at the end of October. I changed it out when it quit working this morning, and was going again in 12 minutes.

    Spare parts are a good thing.
  9. 3bladz

    3bladz Senior Member
    Messages: 173

    I went to radio shack and bought a little plastic electronics box, 3 switches, and the same connector as my hand held. Then I built a hard wired controller that I mounted on a 6" by 20" piece of plywood. This is my back up controller that I keep behind the cab. It is also handy as a trouble shooting device, because I can use a test lite to know for sure whether or not I have power out of the controller.