1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

[B][/B] Fisher MM1 diagnostics ?

Discussion in 'Truck & Equipment Repair' started by PAGE2004, Dec 20, 2009.

  1. PAGE2004

    PAGE2004 Senior Member
    Messages: 102

    Changed the oil in the MM1 - it was milky and tan. Refilled w/ the blue stuff.

    The plow worked great ..... but after a few hrs ... the motor would whine and eventually could hardly lift the plow.... now it doesnt work at all. The red light is on the controller box , but when the joystick is moved any position , no electric motor sound and no alternator drain on the dash.

    Im gonna hook up 12v to the electric motor bolt on the side , but then what ??

    New Pump New electric motor New relay ???

    Always during a storm .

    Thanks ... I gotta get this thing fixed.
  2. Plowfixguys

    Plowfixguys Senior Member
    Messages: 222

    Check the motor and solenoid. Sounds like the motor died. See if you have 12 volts at the motor when operating the plow, if you do replace the motor, if you dont go to the solenoids and grounds.
  3. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    Given that it died slowly, I would be inclined to say it's the motor. Do you hear the relay clicking under the hood?
  4. PAGE2004

    PAGE2004 Senior Member
    Messages: 102

    No relay clicking under the hood .... absolutely nothing happens when the joystick controls are moved.
  5. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    Use a screwdriver to short across the big terrminals on the relay and see if the motor fires.
  6. Plowfixguys

    Plowfixguys Senior Member
    Messages: 222

    Is the controller powered up? Also see if you have power at the solenoid when you operate the controller.
  7. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Ditto. And if it does run replace the underhood solenoid.
  8. PAGE2004

    PAGE2004 Senior Member
    Messages: 102

    Will do ..... both suggestions .

    By the way - the wire from the joystick controller connects to a black , small box type thing mounted in the engine near the battery - has some other wires to it also. This thing looks very very rusted and old. Was wondering what this is called ??

    Thanks for the suggestions - be back with results
  9. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    That would be the under hood solenoid I spoke of. And if it looks that bad don't mess around, replace it.
  10. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    Make sure you unhook the positive wire from the battery before changing the relay.

    If you need one tonight, call around to your plowing buddies. Good chance someone has one in the glovebox or behind the seat.
  11. PAGE2004

    PAGE2004 Senior Member
    Messages: 102

    The outcome :

    I applied 12v to the positive stud on the side of the motor , and it spinned , also the joystick controls worked in the cab while this 12v was attached.

    Got a new solenoid for 50 bucks and solved the problem.

    I checked the blue fluid level , it was down a few ounces , the plow still moves slower than it should .... any ideas ?

    Fluid was changed very recently.

    Thanks for the valuable advice.
  12. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,329

    Last winter was the first winter I used my plow. It had been sitting for 5 years or so covered up good. It would wine a little when I would try to raise it. I drained all the fluid and refilled. I also added a little Seafoam Transtune to the fluid to help get any water out. seemed to work good. I have only used the plow a couple times this winter. The noise has come back some. I need to take it apart and give it a good going over.

    Anyways, try a little transtune in the fluid just in case there is still some condensation in the fluid.
  13. plowguy43

    plowguy43 PlowSite Fanatic
    Messages: 5,281

    Hey bud, Napa sells the Fisher Solenoid's for $16- I bought 2 last week- don't mess around with the aftermarket ones, I had one fail after 2 storms.

    If your plow is slow, I'm thinking your filter is clogged up from the old fluid. You have to remove your motor then pump to get to it, clean it with parts cleaner/brake cleaner, and it should be ok for the time being or just replace that as well since its cheap.
  14. PAGE2004

    PAGE2004 Senior Member
    Messages: 102

    I paid like 60 bucks for a Fisher solenoid - you say they're at Napa for $16 ?

    I was advised to
    Remove the plastic cover on the MM1 pump -
    Remove the 3 solenoids one at a time and check for sludge build up ( screens )

    Under the motor there are NO screens in the reservoir correct ??
    Can stuff clog in the reservoir ??

    PS- I'll pick up some TRANSTUNE.
  15. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    there is a filter in the resevoir on the pump. you must clean it.
  16. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    You need to find a new dealer that wont srew you. List from Fisher is $13.00.
  17. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Could be selling the HD Trombetta's as replacements. Price would be about right then.
  18. mansf123

    mansf123 Senior Member
    from mass
    Messages: 817

    i payed 11 bucks for a solanoid
  19. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,039

    When you replaced the fluid, did you pull the pump out and replace the pick up filter attached to it as well as clean the base of the reservoir? If you just dumped the fluid, and replaced it there may still be gunk in there slowing it down, especially if you didn't replace the pick up filter.

    $60 for a Motor Relay??? WTF
  20. PAGE2004

    PAGE2004 Senior Member
    Messages: 102

    Hopefully , I can post the pictures here for those of you that might have the same problem with a slow operating MM1 .

    Pic one shows the the pump reservoir with the CLEANED screen attached to the side of the pump. I cleaned it with the air hose at low pressure.

    Pic two shows the screen itself .. loaded with sludge.

    Pic three shows the 3 solenoids located under the black cover which the electric wires hook to. One at a time , remove each solenoid , then slide the electrical piece back on the stem and hook 12 volts ( both positive and negative ) to either electrical plugs . The solenoid should click and open and close freely ...if not ... they need to be replaced.

    My pump goes back on tomorrow and I think the sludged up fluid screen was my problem .

    We'll see.

    Next issue will be to find out why my Meyer electric e47 is slow damn slow after screen changes and new fluid.