1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

At witts end with my E57

Discussion in 'Meyer / Diamond Products Discussion' started by Aveerainc, Mar 2, 2009.

  1. Aveerainc

    Aveerainc Senior Member
    from NH
    Messages: 129

    I need serious help with my 3 year old E57 set up used to plow my driveway. This morning I started the vehicle ( stored inside my garage) and the the touch pad would not light up or work. I switched the touch pad off, waited 1 minute, turned it on and it lit up and worked. I made one pass and then nothing worked. I turned off the touch pad and waited 1 minute, turned it on and the touch pad lit up. As soon as I went to lower the plow the touch pad light went off and nothing worked. I switched it off, waited 1 minute, turned it on and it did not work. I then waited a few minutes and it worked. I made 3 passes and the touch pad stopped working again.

    I don't get a red light on the touch pad telling me there is an overload, and when it does work, I can raise, lower and angle left/right without a problem.

    I have a brand new starter solenoid so we can rule this out. But one thing I did notice is the touch pad light is very dim- could it be my vehicle battery or alternator? Or is it plow related?

    This thing has been acting up all season and the nearest dealer is 45 minutes away - they had it in over the summer for annual fluid change and gave it a clean bill of health.

    Any help you can give is greatly appreciated.
  2. 04sd

    04sd Senior Member
    from pa
    Messages: 266

    Maybe a bad ground connection. I'd start by checking/cleaning all of the grounds, both controler and pump, and checking all plug-in connectors for good contact.
  3. Aveerainc

    Aveerainc Senior Member
    from NH
    Messages: 129

    I'm keeping my fingers crossed and hope I fixed it. Today I spoke with ken fowler (if you are a member then many thanks!) and he suggested I try the fuse as well as the power supply going to the fuse box (under the hood on my jeep). I made sure the gray wire was snug into the fuse box running off the aux fan (it was a bit lose) and that seems to have done the trick. I plowed for 15 minutes without a hiccup which is night and day better than before. Hope this finally solved the problem.