99' chevy 4WD prob.

Arc Burn

PlowSite.com Addict
Alright boys,got a 99'Chevy half ton Z-71 Ext.cab(old body style)with push button 4 WD.Twice last week i pushed the 4WD button,the light came on but i spun like crazy,only 2WD.Pulled in the shop to check it out and you can here the actuator kick over and it seems to be working now but im a little skeptikal of this,it could really suck this winter if this thing decides not to work.Anybody have this problem or got the fix i'd love to know! Thanks for the help
 
OP
Arc Burn

Arc Burn

PlowSite.com Addict
90plow,the acutator is electric and the early chevys,88-94 or so were thermaly activated,once you pulled your lever you waited for the actuator to heat up and engage,chevy soon came out with a kit that activates instantly,i put one on my 95,maybe you already knew all that but maybe that could be your problem,i've heard stories of those units taking miles or even minutes to activate but the new ones are instant,what bothers me is sometimes it works,sometimes it dont!and the light always turns from 2wd to 4wd when you push the button.
 

90plow

Senior Member
Location
New Jersey
I had this problem the other day i put it in four wheel and it wont come out unless i turn the truck off in N whats the problem?
Eric
 
OP
Arc Burn

Arc Burn

PlowSite.com Addict
I would say your counting the days till your actuator says goodbye! I am not in any way posotive of that but thats what it sounds like.New one from the dealer which would be the updated part runs around $100.
 

Top Forums

Similar threads

Similar threads

Top