1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

8611LP blade wont drop

Discussion in 'Blizzard Plows Discussion' started by cl733, Dec 16, 2014.

  1. cl733

    cl733 Senior Member
    from Canada
    Messages: 263

    This has me baffled , mind you I haven't played with a problem like this before, ill tell you a few things ive noticed and tried and see if anyone can help
    we just put a new switch on today cause the guy driving it said the claw wouldn't work, previous to that he said with the blade lifted it would drop and seemed like a squeeling coming from the controller, the blade wouldn't stay up unless he switched to power hitch on the switch
    we had put a jumper wire from just below the controller in the main harness , hitch side of the molex plug directly to the solenoid, that's the one to switch the motor on, the wire was pinched on something and wasn't sending the signal , we needed the plow so a quick fix was cut the original wire as power was coming from the controller but not making it to the solenoid and that worked fine for the whole day
    so now with the blade lifted it wont come down, using the power hitch controls the blade will lift but wont let it still come down,in the down mode it will click the solenoids ,but wont start the motor I direct wired solenoid 5 and 8, thru the connector closest to the solenoids and with the pump running sounds like its bypassing,
    the power hitch down mode is clicking both solenoids, with both cartridges out and in my hand and being powered up number 8 seems to move enough to squirt a little oil, number 5 clicks but hardly moves at all, even with both cartridges removed the blade is still hanging in the air rock solid
    on power hitch down mode both orange wires get charged, we tried a different diode dongle from another blade , no difference
    Tomorrow im going to put a complete new truck side harness in just because we have one and the original install seems really messy
    anybody have any ideas at all, the squeeling in the controller has me wondering,, how does the power make it back on power hitch down to start the motor solenoid,maybe there are more wires damaged in the harness as it was run under the console with extreme pressure on it
    and why wouldn't charging S5 and S8 with the pump running drop the blade to open the claw
    any help would be greatly appreciated
  2. cl733

    cl733 Senior Member
    from Canada
    Messages: 263

    Problem solved,first off I should say this truck had the original ph1 truck to blade connector, but it had been cut off and replaced by a quick connect for the power , and 2 7 pin round plugs for the rest of the wires, we did put in a new harness and when one of the plug receptacles was taken apart there was a brown wire not hooked up, that would explain why the power hitch wouldn't run the motor in the down position ,after rewiring everything on the truck , everything worked properly but the power hitch would not power down the claw, motor ran but it just bypassed and wouldn't open the claw, we replaced the solenoid on S5, and opened up the blade drop speed to full on and it worked perfect
    It could have surely been the replacement of the brn/whi with the jumper wire we ran as in the 7 pin recepiacle , because upon reassembly the brn and brn/whi are put in the same pin , I think the brn had worked out originally and made the brn/whi not made contact , the jumper cured that problem until the power hitch was needed , and the second problem showed up.
    The buzzing in the controller , I don't know , it could have maybe been the operator that was buzzing, cause it all works good now