1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

86 Chev unimount issues

Discussion in 'Western Plows Discussion' started by TTBoy77, Nov 21, 2006.

  1. TTBoy77

    TTBoy77 Member
    Messages: 87

    I have an 86 chev 3/4 ton with an 7'6" pro plow. and a cab command controller. After blowing a circuit board in the controller, I found out about the mods. on Western's website. I then did the mods (cutting the orange and black by the motor relay and then 12 inches from the white connector and running that directly to the batt. ground) and replaced my board with a brand new Western replacement one. Still had nothing, but I now had power to the controller. After going through the flow charts for the fourth time, they still pointed me towards a faulty controller. Then all of a sudden the blade worked fine, for about 2 minutes, much to my chagrin. Now nothing happens. The 6 amp fuse is good and I still get power to controller. The float light comes on when lower is held, like it is supposed to. There is some clicking coming from the controller and it sounds to me like it is trying to work but can't. Could it be the white connectors? They seem fine but I am at a loss. Any help would be greatly appreciated as the snow will be flying soon here in WI.
  2. TTBoy77

    TTBoy77 Member
    Messages: 87

    I Win

    I figured it out. The new motor relay was working intermitently. I replaced it with another new one and all seems to be good. Now I just have to work on my lighting and I'll be good to go. First I have to do the timing belt on the 'ol lady's 99 Subaru Outback. Will post any problems with the lighting.xysport

    p.s. I love the website and I will try to help out you guys with whatever I can.