1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

8100 pump runs constantly

Discussion in 'Blizzard Plows Discussion' started by DIYhard, Jan 5, 2013.

  1. DIYhard

    DIYhard Junior Member
    Messages: 9

    First year for the new style Blizzard. We run 5 other 810's and love them but got this 8100 with the truck we purchased this season.
    Last snowfall the pump quit - found a terminal broken off the pump solenoid. Once changed out the pump runs constantly. Tested the leads and the trigger wire to the solenoid is hot all the time even with the system shut off. Only way to power down the solenoid is to unplug the plow itself.

    Any ideas? Can't find any info on the "modules" and I suspect the plow mounted module is faulty since there are no relays on the plow side and only 2 on the truck side and I've disconnected both and still have voltage on the trigger wire.

    New to posting but have been using the site for info for over 5years. A GREAT asset!
  2. Jerre Heyer

    Jerre Heyer Senior Member
    Messages: 948

    On the new units there is constant power to the solenoid. It is triggered by the black wire giving it ground.

    Pict of your solenoid and wiring please as it will help diagnose.
  3. DIYhard

    DIYhard Junior Member
    Messages: 9

    does that mean that there is a special solenoid? I stock a four post solenoid from the meyers dealer (we have no blizzard dealer). I'll work on posting a pic, but basically the large power wires are on the main posts, the red wire on S and the black wire on I. I have tried reversing the small wires with the same result. Is it possible then that I have damaged the new solenoid by putting the small wires on backwards first?

    On the old blizzard style we simply put the trigger wire on the small post closest to the large post that receives the power feed from the battery. This is what I did in this case as well.
  4. bliz&hinikerDLR

    bliz&hinikerDLR Senior Member
    Messages: 553

    Not really a special solenoid (although Blizzard now recommends using a intermittant use solenoid) but a typical four post solenoid should work. I am not familiar with Meyer however. But lets assume that it is good. Somehow the solenoid is getting ground. It may go back to your post breaking off or it may be something wasn't reassembled correctly. Here is a diagram of electrical. Be sure everything by motor and solenoid was put back in the right spot.

    Attached Files:

  5. DIYhard

    DIYhard Junior Member
    Messages: 9

    ok, seems I need to enlist my kid to figure out "uploading" a photo :p

    Double checked wiring, only removed the solenoid and nothing else. Did a test on the two small wires based on the ground wire being the trigger. I have continuity through those wires at all times unless I unplug the B port on the Plow side module. I have no voltage on the small contacts in the plow harness plug (which is plugged in correctly) so the fault must be on the plow side.
    The way I understand it, regardless of which wire is the trigger there should be no continuity unless a controller button is pushed. Am I wrong there?
    Also double checked for a damaged wire going to ground but everything looks like new. Also tested the replacement solenoid on another plow and it works fine. Sending out for a new module in case I need it (takes a few days to get parts here) $275.00 :(

    I'm already liking my old 810's better! If only I could have the new controller on the old harness...
  6. bliz&hinikerDLR

    bliz&hinikerDLR Senior Member
    Messages: 553

    Two things to check while waiting for your module.

    First, check your ground at the battery to be absolutely sure it's a good connection. I had one truck that had a weak ground connection to the battery and it made the plow misbehave. However I can't remember if it made the solenoid click constantly or made motor run all the time.

    Second ... without the solenoid ground activation wire hooked up, hook the plow up normally and check to see if you have magnetization at any of the coils. Basically checking to be sure that there is not a function stuck in the "on" position, such as if you had a pair of bad PH switches or damage to the wires leading to the switches.
  7. DIYhard

    DIYhard Junior Member
    Messages: 9

    Ok, plow is up and running. Thanks for all the help. Switched out the module and the solenoid from Blizzard. Works fine again. Switched the solenoid back to be sure my standard 4 post solenoid works and it does so that shouldn't be a problem for anyone. In fact the solenoid from blizzard comes in a Western package! So if your looking for a "factory" replacement (so the mounting screws all line up) it is a Western part.
    Another FYI - the fuse block on the plow side (the one with 4amp fuses) has 2 fuses - one for the hand controller and one for the switches on the side of the plow. SO if you have power at the plow but not the controller or Visa-versa then one of these fuses may be open. (thanks Blitz... for the schematic)
  8. Kale Lawn

    Kale Lawn Senior Member
    from Ohio
    Messages: 107

    that happened to me this winter... ended up being the plow side module. Thank goodness it was still under warranty! Took about 2 hours to figure it out though! Including pulling the grille and driver side headlight on my 2011 F-550 to check the fuses! Runs great now. Die-electric grease in a must on every connection!