1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

810 wont respond

Discussion in 'Blizzard Plows Discussion' started by tjcezar, Feb 3, 2011.

  1. tjcezar

    tjcezar Member
    Messages: 63

    Plow stop working when arriving at a job. when I hit the control button the solenoid just clicks. after messing with it it eventually activated and went up nbut it did so very slowly. After getting back to the shop is just wont work. a couple times it worked for a second then stopped again. After testing everything I thought it was the solenoid so I put a new one on and that was not it but when the power line was off the pump motor and we hit the switch I would get a 12.? reading but when I hooked to the motor and tested again it would show 0.0 so I then thought the motor has to be bad so I put a new motor in it and still has not fixed it. All my power and grounds are clean and in the same place they've been for years what am I missing? are there fuses somewhere? I even cleaned the heck out of the harness plugs:realmad: help me out.
  2. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    Float coil?
    Last edited: Feb 3, 2011
  3. tjcezar

    tjcezar Member
    Messages: 63

    found problem. A loose eye fitting on the battery wire. Would give me 12v reading till I put a load on it :realmad: