1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

810 won't go down.

Discussion in 'Blizzard Plows Discussion' started by Greenery, Jan 15, 2012.

  1. Greenery

    Greenery 2000 Club Member
    Messages: 2,438

    Hey guys, I finally hooked up this 810 I picked up a couple months ago and it has some issues.

    I got it all hooked up, power hitch worked great, jump in the truck checked all the functions, everything worked great. So later in the day we had got about an inch of snow so I figure I would take this thing out to a property and run it a while to make sure everything works.

    So I hop in the truck test all the functions again everything works BUT it didn't lower on the first attempt so I check the plug and try again and it works, so I figured it was just the plug.
    Now I get to my account make a couple passes and everything works great. Third or fourth pass I went to put blade down and nothing, motor doesnt run and if I hold it it goes into float red light turns on but the plow stays fully raised. So I try the power hitch switch and that runs the motor but the valve doesn't seem to be opening as the motor is straining. Every other function works fine, just no lower.

    So now I'm sitting here with the thing fully raised and no way to get it off the truck. Also with it fully raised I can't even get the cover off to get to the pump.

    Any ideas on what I should check for my lowering problem?

    Also I figure I'll support the moldboard with jack stands, unhook the lines for the lift cylinder and lower it with a floor jack.
  2. beam

    beam Senior Member
    from pa
    Messages: 314

    check plow side harness pins for breakage and corrision
  3. Greenery

    Greenery 2000 Club Member
    Messages: 2,438

    Thanks, I did happen to check that and everything looked good.

    What makes me think it's somthing with the pump is that the power hitch switch activates the motor but not the valve or solenoid, along with nothing happening when using the control box.

    I'm not real familiar with these hydraulic pumps so all help is appreciated.
  4. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    If you can't get your cover off, you need to crack a line on the lift cylinder to bleed off pressure, BUT NOT UNTIL YOU SUPPORT YOUR PLOW IN THE RAISED POSITION WITH A FLOOR JACK. DO THIS WITH EXTREME CAUTION.

    Then you need to test for magnetism with float engaged on the float coil. You didn't mention a year or model, so I can't tell you what number to look for. No magnetism=no power. Look for bad connection, broken wire, could be bad coil, but prob not.

    If the blade will lift, as you say it will, it is NOT your pump.
  5. Greenery

    Greenery 2000 Club Member
    Messages: 2,438

    Thanks, yes I will be using jackstands to support while removing the line along with a floor jack to lower it.

    The plow is a 2004 model 810.

    How do i test for magnetism? I'm guessing I need to check S5 and S8?

    Yes you are correct the motor is just fine, I guess I should have said manifold or valves.

    I'm new to Blizzard and I've never needed to troubleshoot a pump/manifold problem before so bear with me.

    When dropping the plow is it powered down or gravity? What i'm wondering is if the motor should try to run when using the joystick to lower. Similar to how the power hitch turns on the motor when disengaging or lowering the plow from that switch.

    Thanks for your help.
  6. bliz&hinikerDLR

    bliz&hinikerDLR Senior Member
    Messages: 553

    Blizzards are gravity drop plows. The motor does not run when the joystick is put in the float position.
  7. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    Correct, s5 is float, s8 is lower. Unscrew th 3/4 nut on that valve, slide the coil off, stick a screw driver in the coil, place control in float.
  8. JohnnyU

    JohnnyU 2000 Club Member
    Messages: 2,040

    Have you checked your drop speed adjustment? I had mistakenly turned mine in too far and it would lock the system preventing the plow from lowering. I did a fair bit of troubleshooting and felt pretty embarrassed when I discovered the real issue.

    Just a thought.

    Some of your recent posts have given me reason to question a couple of things about you, whether your aren't really reading people's posts, your reading comprehension is less-than-stellar, or you just don't know what you're talking about.

    It was clearly stated that the POWER HITCH switch would actuate the motor, but none of the valves. The motor DOES run when the power hitch switch is depressed down into the "LOWER" position. No one said that the motor should run when in "FLOAT" on the controller.

  9. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    Good point, JohnnyU, on the drop speed adj.
  10. Greenery

    Greenery 2000 Club Member
    Messages: 2,438

    Ok guys I did some more testing.

    I opened up the drop speed a little with no change.

    I then checked for current at the truck side plug, I'm finding the float wire (orange) is powered with the float engaged (red light on). I then checked the lift wire (white) and that only receives power when the lift function is activated. Should this also be powered when lowering?
    Last edited: Jan 16, 2012
  11. Greenery

    Greenery 2000 Club Member
    Messages: 2,438

    Wtf, After checking a couple other things my controller is no longer lighting up the float light and the float terminal (orange) now has constant power going to it with no function activated on the controller.

    These are all at the truck side plug by the way.
  12. bliz&hinikerDLR

    bliz&hinikerDLR Senior Member
    Messages: 553

    Do any functions work? Did you possibly short a wire when you were testing your plug? The inline fuse under the dash may have blown if you did and would cut power to control ... therefor no light on control.
    I don't know why you would have power on the float wire if the control was dead though unless you had a short.
  13. Greenery

    Greenery 2000 Club Member
    Messages: 2,438

    Yup all functions work other than lower and the controller is receiving power. I did get it off the truck so next I'm going to troubleshoot it with a spare truck harness I have. I picked up a new coil and a diode pack just in case.

    My main concern now is the float light not lighting up suddenly and a constant power through the float wire. I'm wondering if the little time delay relay got fried somehow.
  14. Greenery

    Greenery 2000 Club Member
    Messages: 2,438

    Thanks for the help guys, it was the diode pack.

    I have a couple other issues I'll bring up in a new thread.